summaryrefslogtreecommitdiffstats
path: root/mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:28:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:28:34 +0000
commit39bea55b2de0eabc2a876ed40dd664d1f80cbcd2 (patch)
tree440d70559330bcdfe14968d44dd5d33ea570281e /mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare
parentReleasing progress-linux version 256.5-2~progress7.99u1. (diff)
downloadsystemd-39bea55b2de0eabc2a876ed40dd664d1f80cbcd2.tar.xz
systemd-39bea55b2de0eabc2a876ed40dd664d1f80cbcd2.zip
Merging upstream version 256.6.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare')
-rwxr-xr-xmkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare5
1 files changed, 3 insertions, 2 deletions
diff --git a/mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare b/mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare
index 6028dc3..4fef26f 100755
--- a/mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare
+++ b/mkosi.images/build/mkosi.conf.d/centos-fedora/mkosi.prepare
@@ -17,7 +17,7 @@ mkosi-chroot \
--query \
--buildrequires \
--define "_topdir /var/tmp" \
- --define "_sourcedir pkg/$PKG_SUBDIR" \
+ --define "_sourcedir $PWD/pkg/$PKG_SUBDIR" \
"pkg/$PKG_SUBDIR/systemd.spec" |
grep --invert-match --regexp systemd --regexp /bin/sh --regexp "rpmlib(" --regexp udev --regexp grubby --regexp sdubby |
sort --unique |
@@ -32,10 +32,11 @@ sed '/Source0/d' --in-place "pkg/$PKG_SUBDIR/systemd.spec"
until mkosi-chroot \
rpmbuild \
-br \
+ --noprep \
--build-in-place \
--with upstream \
--define "_topdir /var/tmp" \
- --define "_sourcedir pkg/$PKG_SUBDIR" \
+ --define "_sourcedir $PWD/pkg/$PKG_SUBDIR" \
--define "_build_name_fmt %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm" \
"pkg/$PKG_SUBDIR/systemd.spec"
do