summaryrefslogtreecommitdiffstats
path: root/network/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /network/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'network/meson.build')
-rw-r--r--network/meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/network/meson.build b/network/meson.build
new file mode 100644
index 0000000..2a472f4
--- /dev/null
+++ b/network/meson.build
@@ -0,0 +1,40 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+if conf.get('ENABLE_NETWORKD') == 1
+ install_data(
+ '80-6rd-tunnel.network',
+ '80-container-host0.network',
+ '80-container-vb.network',
+ '80-container-ve.network',
+ '80-container-vz.network',
+ '80-vm-vt.network',
+ '80-wifi-adhoc.network',
+ install_dir : networkdir)
+
+ example_network_files = files(
+ '80-auto-link-local.network.example',
+ '89-ethernet.network.example',
+ '80-wifi-ap.network.example',
+ '80-wifi-station.network.example',
+ )
+
+ install_data(
+ example_network_files,
+ install_dir : networkdir)
+
+ if get_option('default-network')
+ foreach f : example_network_files
+ install_data(
+ f,
+ rename : fs.replace_suffix(fs.name(f), ''),
+ install_dir : networkdir)
+ endforeach
+ endif
+endif
+
+install_data('99-default.link',
+ install_dir : networkdir)
+
+if install_sysconfdir
+ install_emptydir(sysconfdir / 'systemd/network')
+endif