summaryrefslogtreecommitdiffstats
path: root/src/dissect/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/dissect/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/dissect/meson.build')
-rw-r--r--src/dissect/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/dissect/meson.build b/src/dissect/meson.build
new file mode 100644
index 0000000..e422dbd
--- /dev/null
+++ b/src/dissect/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ executable_template + {
+ 'name' : 'systemd-dissect',
+ 'public' : true,
+ 'conditions' : ['HAVE_BLKID'],
+ 'sources' : files('dissect.c'),
+ },
+]
+
+if conf.get('HAVE_BLKID') == 1
+ install_emptydir(sbindir)
+ meson.add_install_script(sh, '-c',
+ ln_s.format(bindir / 'systemd-dissect',
+ sbindir / 'mount.ddi'))
+endif