summaryrefslogtreecommitdiffstats
path: root/src/hostname/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/hostname/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/hostname/meson.build')
-rw-r--r--src/hostname/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/hostname/meson.build b/src/hostname/meson.build
new file mode 100644
index 0000000..27c9b84
--- /dev/null
+++ b/src/hostname/meson.build
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-hostnamed',
+ 'dbus' : true,
+ 'conditions' : ['ENABLE_HOSTNAMED'],
+ 'sources' : files('hostnamed.c'),
+ },
+ executable_template + {
+ 'name' : 'hostnamectl',
+ 'public' : true,
+ 'conditions' : ['ENABLE_HOSTNAMED'],
+ 'sources' : files('hostnamectl.c'),
+ },
+]
+
+if conf.get('ENABLE_HOSTNAMED') == 1
+ install_data('org.freedesktop.hostname1.conf',
+ install_dir : dbuspolicydir)
+ install_data('org.freedesktop.hostname1.service',
+ install_dir : dbussystemservicedir)
+ install_data('org.freedesktop.hostname1.policy',
+ install_dir : polkitpolicydir)
+endif