summaryrefslogtreecommitdiffstats
path: root/src/journal/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:45 +0000
commitefeb864cb547a2cbf96dc0053a8bdb4d9190b364 (patch)
treec0b83368f18be983fcc763200c4c24d633244588 /src/journal/meson.build
parentReleasing progress-linux version 255.5-1~progress7.99u1. (diff)
downloadsystemd-efeb864cb547a2cbf96dc0053a8bdb4d9190b364.tar.xz
systemd-efeb864cb547a2cbf96dc0053a8bdb4d9190b364.zip
Merging upstream version 256.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/journal/meson.build')
-rw-r--r--src/journal/meson.build44
1 files changed, 32 insertions, 12 deletions
diff --git a/src/journal/meson.build b/src/journal/meson.build
index 36600bf..9f0e699 100644
--- a/src/journal/meson.build
+++ b/src/journal/meson.build
@@ -12,6 +12,7 @@ sources = files(
'journald-stream.c',
'journald-syslog.c',
'journald-wall.c',
+ 'journald-socket.c',
)
sources += custom_target(
@@ -28,11 +29,24 @@ libjournal_core = static_library(
userspace],
build_by_default : false)
+journalctl_sources = files(
+ 'journalctl.c',
+ 'journalctl-catalog.c',
+ 'journalctl-filter.c',
+ 'journalctl-misc.c',
+ 'journalctl-show.c',
+ 'journalctl-util.c',
+ 'journalctl-varlink.c',
+)
+
+if conf.get('HAVE_GCRYPT') == 1
+ journalctl_sources += files('journalctl-authenticate.c')
+endif
+
if get_option('link-journalctl-shared')
journalctl_link_with = [libshared]
else
journalctl_link_with = [
- libbasic_gcrypt,
libshared_static,
libsystemd_static,
]
@@ -62,10 +76,10 @@ executables += [
libshared,
],
'dependencies' : [
- liblz4,
+ liblz4_cflags,
libselinux,
- libxz,
- libzstd,
+ libxz_cflags,
+ libzstd_cflags,
threads,
],
},
@@ -90,30 +104,36 @@ executables += [
executable_template + {
'name' : 'journalctl',
'public' : true,
- 'sources' : files('journalctl.c'),
+ 'sources' : journalctl_sources,
'link_with' : journalctl_link_with,
'dependencies' : [
libdl,
- liblz4,
- libxz,
- libzstd,
+ liblz4_cflags,
+ libxz_cflags,
+ libzstd_cflags,
threads,
],
},
journal_test_template + {
'sources' : files('test-journald-config.c'),
'dependencies' : [
- liblz4,
+ liblz4_cflags,
libselinux,
- libxz,
+ libxz_cflags,
],
},
+ test_template + {
+ 'sources' : files(
+ 'test-journald-rate-limit.c',
+ 'journald-rate-limit.c',
+ ),
+ },
journal_test_template + {
'sources' : files('test-journald-syslog.c'),
'dependencies' : [
- liblz4,
+ liblz4_cflags,
libselinux,
- libxz,
+ libxz_cflags,
threads,
],
},