summaryrefslogtreecommitdiffstats
path: root/src/shutdown/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/shutdown/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/shutdown/meson.build')
-rw-r--r--src/shutdown/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/shutdown/meson.build b/src/shutdown/meson.build
new file mode 100644
index 0000000..219f9fd
--- /dev/null
+++ b/src/shutdown/meson.build
@@ -0,0 +1,39 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+systemd_shutdown_sources = files(
+ 'detach-dm.c',
+ 'detach-loopback.c',
+ 'detach-md.c',
+ 'detach-swap.c',
+ 'shutdown.c',
+ 'umount.c',
+)
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-shutdown',
+ 'sources' : systemd_shutdown_sources,
+ 'dependencies' : libmount,
+ },
+ libexec_template + {
+ 'name' : 'systemd-shutdown.standalone',
+ 'sources' : systemd_shutdown_sources,
+ 'c_args' : '-DSTANDALONE',
+ 'link_with' : [
+ libbasic,
+ libshared_static,
+ libsystemd_static,
+ ],
+ 'dependencies' : libmount,
+ 'build_by_default' : have_standalone_binaries,
+ 'install' : have_standalone_binaries,
+ },
+ test_template + {
+ 'sources' : files(
+ 'test-umount.c',
+ 'detach-swap.c',
+ 'umount.c',
+ ),
+ 'dependencies' : libmount,
+ },
+]