summaryrefslogtreecommitdiffstats
path: root/src/user-sessions
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/user-sessions
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/user-sessions')
-rw-r--r--src/user-sessions/meson.build9
-rw-r--r--src/user-sessions/user-sessions.c42
2 files changed, 51 insertions, 0 deletions
diff --git a/src/user-sessions/meson.build b/src/user-sessions/meson.build
new file mode 100644
index 0000000..938e526
--- /dev/null
+++ b/src/user-sessions/meson.build
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-user-sessions',
+ 'conditions' : ['HAVE_PAM'],
+ 'sources' : files('user-sessions.c'),
+ },
+]
diff --git a/src/user-sessions/user-sessions.c b/src/user-sessions/user-sessions.c
new file mode 100644
index 0000000..58054f8
--- /dev/null
+++ b/src/user-sessions/user-sessions.c
@@ -0,0 +1,42 @@
+/* SPDX-License-Identifier: LGPL-2.1-or-later */
+
+#include <errno.h>
+#include <fcntl.h>
+#include <sys/stat.h>
+#include <sys/types.h>
+#include <unistd.h>
+
+#include "fileio.h"
+#include "fileio-label.h"
+#include "fs-util.h"
+#include "main-func.h"
+#include "log.h"
+#include "selinux-util.h"
+#include "string-util.h"
+
+static int run(int argc, char *argv[]) {
+ int r;
+
+ if (argc != 2)
+ return log_error_errno(SYNTHETIC_ERRNO(EINVAL),
+ "This program requires one argument.");
+
+ log_setup();
+
+ umask(0022);
+
+ r = mac_init();
+ if (r < 0)
+ return r;
+
+ /* We only touch /run/nologin. See create_shutdown_run_nologin_or_warn() for details. */
+
+ if (streq(argv[1], "start"))
+ return unlink_or_warn("/run/nologin");
+ if (streq(argv[1], "stop"))
+ return create_shutdown_run_nologin_or_warn();
+
+ return log_error_errno(SYNTHETIC_ERRNO(EINVAL), "Unknown verb '%s'.", argv[1]);
+}
+
+DEFINE_MAIN_FUNCTION(run);