summaryrefslogtreecommitdiffstats
path: root/test/TEST-07-PID1
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /test/TEST-07-PID1
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-07-PID1')
l---------test/TEST-07-PID1/Makefile1
-rwxr-xr-xtest/TEST-07-PID1/test.sh42
2 files changed, 43 insertions, 0 deletions
diff --git a/test/TEST-07-PID1/Makefile b/test/TEST-07-PID1/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-07-PID1/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-07-PID1/test.sh b/test/TEST-07-PID1/test.sh
new file mode 100755
index 0000000..cc8a81f
--- /dev/null
+++ b/test/TEST-07-PID1/test.sh
@@ -0,0 +1,42 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="Tests for core PID1 functionality"
+
+# for testing PrivateNetwork=yes
+NSPAWN_ARGUMENTS="--capability=CAP_NET_ADMIN"
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+test_append_files() {
+ local workspace="${1:?}"
+
+ # We might not be fast enough to hit the limit (20 triggers per 2 secs)
+ # in certain environments, i.e. when running without KVM or when collecting
+ # coverage. Let's help it a bit in such case.
+ if ! get_bool "$QEMU_KVM" || get_bool "$IS_BUILT_WITH_COVERAGE"; then
+ mkdir -p "$workspace/etc/systemd/system/issue2467.socket.d"
+ printf "[Socket]\nTriggerLimitIntervalSec=10\n" >"$workspace/etc/systemd/system/issue2467.socket.d/TriggerLimitInterval.conf"
+ fi
+
+ # Issue: https://github.com/systemd/systemd/issues/2730
+ mkdir -p "$workspace/etc/systemd/system/"
+ cat >"$workspace/etc/systemd/system/issue2730.mount" <<EOF
+[Mount]
+What=tmpfs
+Where=/issue2730
+Type=tmpfs
+
+[Install]
+WantedBy=local-fs.target
+Alias=issue2730-alias.mount
+EOF
+ "${SYSTEMCTL:?}" enable --root="$workspace" issue2730.mount
+ ln -svrf "$workspace/etc/systemd/system/issue2730.mount" "$workspace/etc/systemd/system/issue2730-alias.mount"
+
+ image_install logger socat
+}
+
+do_test "$@"