summaryrefslogtreecommitdiffstats
path: root/test/TEST-26-SYSTEMCTL
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /test/TEST-26-SYSTEMCTL
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-26-SYSTEMCTL')
l---------test/TEST-26-SYSTEMCTL/Makefile1
-rwxr-xr-xtest/TEST-26-SYSTEMCTL/test.sh10
2 files changed, 11 insertions, 0 deletions
diff --git a/test/TEST-26-SYSTEMCTL/Makefile b/test/TEST-26-SYSTEMCTL/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-26-SYSTEMCTL/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-26-SYSTEMCTL/test.sh b/test/TEST-26-SYSTEMCTL/test.sh
new file mode 100755
index 0000000..64accf8
--- /dev/null
+++ b/test/TEST-26-SYSTEMCTL/test.sh
@@ -0,0 +1,10 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="systemctl-related tests"
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+do_test "$@"