summaryrefslogtreecommitdiffstats
path: root/test/TEST-36-NUMAPOLICY
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /test/TEST-36-NUMAPOLICY
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-36-NUMAPOLICY')
l---------test/TEST-36-NUMAPOLICY/Makefile1
-rwxr-xr-xtest/TEST-36-NUMAPOLICY/test.sh22
2 files changed, 23 insertions, 0 deletions
diff --git a/test/TEST-36-NUMAPOLICY/Makefile b/test/TEST-36-NUMAPOLICY/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-36-NUMAPOLICY/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-36-NUMAPOLICY/test.sh b/test/TEST-36-NUMAPOLICY/test.sh
new file mode 100755
index 0000000..9548ebb
--- /dev/null
+++ b/test/TEST-36-NUMAPOLICY/test.sh
@@ -0,0 +1,22 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="test NUMAPolicy= and NUMAMask= options"
+TEST_NO_NSPAWN=1
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+if qemu_min_version "5.2.0"; then
+ QEMU_OPTIONS+=" -object memory-backend-ram,id=mem0,size=${QEMU_MEM:-768M} -numa node,memdev=mem0,nodeid=0"
+else
+ QEMU_OPTIONS+=" -numa node,nodeid=0"
+fi
+
+if [[ "$(uname -m)" =~ ^(s390x|ppc)$ ]]; then
+ echo "QEMU doesn't support NUMA nodes on $(uname -m), skipping the test"
+ exit 0
+fi
+
+do_test "$@"