summaryrefslogtreecommitdiffstats
path: root/test/TEST-58-REPART
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /test/TEST-58-REPART
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-58-REPART')
l---------test/TEST-58-REPART/Makefile1
-rwxr-xr-xtest/TEST-58-REPART/test.sh31
2 files changed, 32 insertions, 0 deletions
diff --git a/test/TEST-58-REPART/Makefile b/test/TEST-58-REPART/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-58-REPART/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-58-REPART/test.sh b/test/TEST-58-REPART/test.sh
new file mode 100755
index 0000000..14898b5
--- /dev/null
+++ b/test/TEST-58-REPART/test.sh
@@ -0,0 +1,31 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="test systemd-repart"
+IMAGE_NAME="repart"
+IMAGE_ADDITIONAL_ROOT_SIZE=1000
+TEST_FORCE_NEWIMAGE=1
+
+# shellcheck source=test/test-functions
+. "$TEST_BASE_DIR/test-functions"
+
+test_append_files() {
+ if ! get_bool "${TEST_NO_QEMU:=}"; then
+ install_dmevent
+ instmods dm_verity =md
+ instmods erofs
+ generate_module_dependencies
+ image_install veritysetup
+ image_install -o mksquashfs
+ image_install -o mkfs.erofs
+ fi
+
+ inst_binary mcopy
+ image_install mkswap
+ if command -v openssl >/dev/null 2>&1; then
+ inst_binary openssl
+ fi
+}
+
+do_test "$@"