summaryrefslogtreecommitdiffstats
path: root/test/TEST-83-BTRFS
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /test/TEST-83-BTRFS
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-83-BTRFS')
l---------test/TEST-83-BTRFS/Makefile1
-rwxr-xr-xtest/TEST-83-BTRFS/test.sh30
2 files changed, 31 insertions, 0 deletions
diff --git a/test/TEST-83-BTRFS/Makefile b/test/TEST-83-BTRFS/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-83-BTRFS/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-83-BTRFS/test.sh b/test/TEST-83-BTRFS/test.sh
new file mode 100755
index 0000000..72d1244
--- /dev/null
+++ b/test/TEST-83-BTRFS/test.sh
@@ -0,0 +1,30 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="test btrfs-util"
+
+TEST_NO_NSPAWN=1
+FSTYPE=btrfs
+IMAGE_NAME="btrfs"
+TEST_FORCE_NEWIMAGE=1
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+if ! command -v btrfs >/dev/null || ! command -v mkfs.btrfs >/dev/null; then
+ echo "TEST: $TEST_DESCRIPTION [SKIPPED]: btrfs not supported by host" >&2
+ exit 0
+fi
+
+if ! btrfs filesystem mkswapfile --help >/dev/null; then
+ echo "TEST: $TEST_DESCRIPTION [SKIPPED]: 'btrfs filesystem' doesn't support 'mkswapfile' subcommand" >&2
+ exit 0
+fi
+
+test_append_files() {
+ install_btrfs
+ image_install sync
+}
+
+do_test "$@"