summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog25
-rw-r--r--debian/clean5
-rw-r--r--debian/control2
-rw-r--r--debian/not-installed10
-rwxr-xr-xdebian/rules68
-rwxr-xr-xdebian/systemd.install1
-rw-r--r--debian/tests/control42
7 files changed, 72 insertions, 81 deletions
diff --git a/debian/changelog b/debian/changelog
index fa120d9..7f81ed3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+systemd (256.4-3) unstable; urgency=medium
+
+ * Drop redundant pot build. This was added many years ago, when
+ apparently the upstream pot generation wasn't run or wasn't working.
+ This is not the case anymore, pot files are regenerated upstream and
+ checked in on every release, so this manual step just updates the
+ timestamp in the existing template and nothing else. Drop it.
+ * Use debian/clean instead of override in d/rules
+ * Stop shipping empty /etc/init.d directory. We do not have any need for
+ it, and will soon stop supporting legacy init files, so stop shipping
+ it
+ * Use d/not-installed instead of manual removals. We no longer install
+ in the main package with a wildcard so we do not need to manually
+ delete files, listing them in d/not-installed is sufficient. The only
+ exceptions are files picked up by directory/wildcard entries in
+ dh_install that have to be deleted.
+ * autopkgtest: run upstream test last. It is the most complex and thus
+ the most likely to show temporary failures, so move it last so that
+ it's easier to read the logs
+ * autopkgtest: use hint-testsuite-triggers to ensure other packages
+ changes trigger our testsuite
+ * Depend on new linux-bpf-dev package where available
+
+ -- Luca Boccassi <bluca@debian.org> Sun, 11 Aug 2024 11:53:32 +0100
+
systemd (256.4-2~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..d176c7a
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1,5 @@
+debian/shlibs.local
+src/ukify/test/__pycache__/
+src/ukify/__pycache__/
+tools/__pycache__/
+tools/chromiumos/__pycache__/
diff --git a/debian/control b/debian/control
index 4036b17..029f6a6 100644
--- a/debian/control
+++ b/debian/control
@@ -30,7 +30,7 @@ Build-Depends: debhelper-compat (= 13),
meson (>= 0.60.0),
rsync | meson (>= 1.3.0~),
clang [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1>,
- linux-headers-generic [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1>,
+ linux-bpf-dev [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1> | linux-headers-generic [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1>,
libbpf-dev [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1>,
bpftool [amd64 arm64 ppc64el riscv64 s390x] <!pkg.systemd.nobpf !stage1 !pkg.systemd.upstream>,
linux-tools-generic <pkg.systemd.upstream> | bpftool <pkg.systemd.upstream>,
diff --git a/debian/not-installed b/debian/not-installed
index 149dfb1..b522bde 100644
--- a/debian/not-installed
+++ b/debian/not-installed
@@ -2,3 +2,13 @@
usr/bin/systemd-sysusers.standalone
usr/bin/systemd-tmpfiles.standalone
usr/lib/systemd/systemd-shutdown.standalone
+usr/bin/systemd-repart.standalone
+usr/lib/*.d/README
+usr/lib/udev/*.d/README
+usr/lib/sysctl.d/50-default.conf
+usr/lib/tmpfiles.d/etc.conf
+usr/share/factory/
+usr/bin/systemd-resolve
+usr/share/man/man5/crypttab.5
+etc/init.d/
+etc/X11/xinit/xinitrc.d/
diff --git a/debian/rules b/debian/rules
index 0e77aa5..52fe8a6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -202,19 +202,10 @@ export PATH := $(shell dirname $(bpftool_binary)):$(PATH)
endif
endif
-# The vmlinux.h we want is in the headers package that linux-headers-ARCH depends on,
-# which itself is the package that provides linux-headers-generic that we build depend on.
-# This is available since Trixie. If we can't find it, default to auto for the upstream CI
-# so that it is generated at build time, or disabled for distribution builds, as we don't
-# want to depend on the buildd kernels.
-ifeq ($(DEB_VENDOR),Ubuntu)
-HEADERS_PACKAGE = $(shell dpkg-query --showformat='$${Depends}' --show linux-headers-generic | sed "s/.*\(linux-headers-.*)\)-generic.*/\1/")
-else
-HEADERS_PACKAGE = $(shell dpkg-query --showformat='$${Depends}' --show linux-headers-$(DEB_HOST_ARCH) | sed "s/.*\(linux-headers-.*-$(DEB_HOST_ARCH)\).*/\1/")
-endif
-
-ifneq ("$(wildcard /usr/src/$(HEADERS_PACKAGE)/vmlinux.h)","")
-CONFFLAGS += -Dvmlinux-h=provided -Dvmlinux-h-path=/usr/src/$(HEADERS_PACKAGE)/vmlinux.h
+# TODO: once linux-bpf-dev is available in all releases that we build for, drop the
+# conditional on the wildcard and the alternative dependency on linux-headers-generic
+ifneq ("$(wildcard /usr/include/$(DEB_HOST_MULTIARCH)/linux/bpf/vmlinux.h)","")
+CONFFLAGS += -Dvmlinux-h=provided -Dvmlinux-h-path=/usr/include/$(DEB_HOST_MULTIARCH)/linux/bpf/vmlinux.h
else
ifneq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
CONFFLAGS += -Dvmlinux-h=auto
@@ -239,53 +230,20 @@ execute_before_dh_auto_build:
@echo 'blhc: ignore-line-regexp: .*cc -E.*'
@echo 'blhc: ignore-line-regexp: .* -o src/boot/efi.*'
-execute_after_dh_auto_build:
- # generate POT file for translators
- ninja -C obj-$(DEB_HOST_GNU_TYPE) systemd-pot
-
execute_before_dh_auto_clean:
ifneq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
debian/extra/checkout-upstream
endif
-execute_after_dh_auto_clean:
- rm -f debian/shlibs.local
- # remove Python byte code files
- rm -rf src/ukify/test/__pycache__/
- rm -rf src/ukify/__pycache__/
- rm -rf tools/__pycache__/
- rm -rf tools/chromiumos/__pycache__/
- rm -f po/systemd.pot
-
execute_before_dh_install:
- # remove unnecessary / unused files
+ # remove unnecessary / unused files that are picked up by wildcards/directory listings in dh_install
rm -rf debian/tmp/usr/share/doc/systemd/LICENSES/
rm -f debian/tmp/usr/share/doc/systemd/LICENSE.*
- rm -f debian/tmp/etc/init.d/README
- rm -f debian/tmp/usr/lib/*.d/README
rm -f debian/tmp/usr/lib/udev/*.d/README
- rm -f debian/tmp/usr/lib/sysctl.d/50-default.conf
- rm -f debian/tmp/etc/X11/xinit/xinitrc.d/50-systemd-user.sh
- if [ -d debian/tmp/etc/X11/xinit/xinitrc.d/ ]; then \
- rmdir -p --ignore-fail-on-non-empty debian/tmp/etc/X11/xinit/xinitrc.d/; \
- fi
- # remove etc.conf and usr/share/factory for now, we are not using them yet
- find debian/tmp/ -name etc.conf -print -delete
- rm -rf debian/tmp/usr/share/factory/
# replace upstream sysusers.d/basic.conf with proper users for Debian
if [ -d debian/tmp/usr/lib/sysusers.d/ ]; then \
debian/extra/make-sysusers-basic > debian/tmp/usr/lib/sysusers.d/basic.conf; \
fi
- # remove obsolete compat symlink
- rm -f debian/tmp/usr/bin/systemd-resolve
- # we don't want the repart standalone binary for now
- rm -f debian/tmp/usr/bin/systemd-repart.standalone
- # files shipped by cryptsetup
-ifeq (, $(filter stage1, $(DEB_BUILD_PROFILES)))
- rm -f debian/tmp/usr/share/man/man5/crypttab.5
-endif
- # print empty directories, makes it easier to keep *.install files up-to-date
- find debian/tmp -type d -empty -print
execute_after_dh_install-arch:
# disable ctrl-alt-del.target
@@ -311,22 +269,6 @@ endif
endif
endif
- # Remove empty directories from /usr/lib.
- # Those are not strictly needed and can trigger piuparts errors due to
- # accidential directory removal by dpkg on merged-/usr systems.
- if [ -d debian/systemd/usr/lib ]; then \
- find debian/systemd/usr/lib -type d -empty -print -delete; \
- fi
-
- # Can be dropped once upstream CI stops running on Jammy, which needs
- # the old pkla config files, which are created only when building with
- # old polkit versions.
-ifneq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
- if [ -f debian/tmp/var/lib/polkit-1/localauthority/10-vendor.d/systemd-networkd.pkla ]; then \
- dh_install -psystemd var/lib/polkit-1/localauthority/10-vendor.d/systemd-networkd.pkla; \
- fi
-endif
-
override_dh_missing:
dh_missing $(DH_MISSING)
diff --git a/debian/systemd.install b/debian/systemd.install
index e3cd8c1..d240822 100755
--- a/debian/systemd.install
+++ b/debian/systemd.install
@@ -2,7 +2,6 @@
etc/binfmt.d/
etc/credstore/
etc/credstore.encrypted/
-etc/init.d/
etc/kernel/install.d/
etc/ssh/ssh_config.d/20-systemd-ssh-proxy.conf
etc/systemd/journald.conf
diff --git a/debian/tests/control b/debian/tests/control
index 141c0dc..857416d 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -131,6 +131,32 @@ Depends: systemd-tests,
tzdata-legacy | tzdata (<< 2024a-1),
Restrictions: needs-root, isolation-container, breaks-testbed
+Tests: boot-smoke
+Depends: systemd-sysv,
+ systemd-resolved,
+ network-manager,
+ gdm3 [!s390x !riscv64],
+ xserver-xorg-video-dummy,
+Restrictions: needs-root, isolation-container, allow-stderr, breaks-testbed
+
+Tests: build-with-static-libsystemd
+Depends: systemd,
+ systemd-resolved,
+ pkgconf,
+ build-essential,
+ libsystemd-dev,
+ libcap-dev,
+
+# Dummy test so that changes to key packages trigger our autopkgtests on ci.debian.net
+Features: test-name=hint-testsuite-triggers
+Test-Command: /bin/true
+Depends: linux-image-generic,
+ linux-image-amd64 [amd64],
+ linux-image-arm64 [arm64],
+ qemu-system-x86 [amd64],
+ ovmf [amd64],
+Restrictions: hint-testsuite-triggers
+
Tests: upstream
Depends: systemd (>= 254~),
systemd-container (>= 254~),
@@ -201,19 +227,3 @@ Depends: systemd (>= 254~),
uidmap,
jq,
Restrictions: needs-root, allow-stderr, isolation-machine, needs-internet, breaks-testbed
-
-Tests: boot-smoke
-Depends: systemd-sysv,
- systemd-resolved,
- network-manager,
- gdm3 [!s390x !riscv64],
- xserver-xorg-video-dummy,
-Restrictions: needs-root, isolation-container, allow-stderr, breaks-testbed
-
-Tests: build-with-static-libsystemd
-Depends: systemd,
- systemd-resolved,
- pkgconf,
- build-essential,
- libsystemd-dev,
- libcap-dev,