summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/rules3
-rwxr-xr-xdebian/systemd-container.install7
-rwxr-xr-xdebian/systemd-container.manpages4
-rwxr-xr-xdebian/systemd.install13
-rwxr-xr-xdebian/systemd.manpages6
-rwxr-xr-xdebian/tests/upstream9
7 files changed, 31 insertions, 24 deletions
diff --git a/debian/changelog b/debian/changelog
index 3bc63b6..228aee0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+systemd (256.5-2) unstable; urgency=medium
+
+ [ Helmut Grohne ]
+ * Fix stage1 build (Closes: #1078821)
+
+ [ Luca Boccassi ]
+ * Disable utmp support, replaced by wtmpdb. utmp is not y2038-safe, util-
+ linux has now turned it off and relies on logind, so disable utmp
+ support in logind too, as it is no longer necessary. wtmpdb replaces
+ the functionality.
+
+ -- Luca Boccassi <bluca@debian.org> Sun, 01 Sep 2024 22:03:06 +0100
+
systemd (256.5-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/rules b/debian/rules
index 52fe8a6..151ce61 100755
--- a/debian/rules
+++ b/debian/rules
@@ -114,6 +114,7 @@ CONFFLAGS = \
-Dresolve=true \
-Dstatus-unit-format-default=combined \
-Dstandalone-binaries=true \
+ -Dutmp=false \
-Dmode=$(if $(filter pkg.systemd.upstream,$(DEB_BUILD_PROFILES)),developer,release)
ifeq ($(filter nocheck,$(DEB_BUILD_PROFILES))$(filter noinsttest,$(DEB_BUILD_PROFILES)),nochecknoinsttest)
@@ -261,7 +262,7 @@ else
install -D --mode=644 debian/extra/resolved.conf.d/cache-no-negative.conf debian/systemd-resolved/usr/lib/systemd/resolved.conf.d/cache-no-negative.conf
endif
-ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
+ifeq (,$(filter stage1 pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
ifeq ($(DEB_VENDOR),Debian)
ifneq ($(TEMPLATE_EFI_ARCH),)
debian/extra/gen-signing-template $(DEB_VERSION) $(DEB_HOST_ARCH) $(TEMPLATE_EFI_ARCH)
diff --git a/debian/systemd-container.install b/debian/systemd-container.install
index 203ae2a..2e82b65 100755
--- a/debian/systemd-container.install
+++ b/debian/systemd-container.install
@@ -1,5 +1,6 @@
#!/usr/bin/dh-exec
usr/bin/importctl
+<pkg.systemd.upstream> usr/bin/updatectl
<pkg.systemd.upstream> usr/bin/systemd-vmspawn
<pkg.systemd.upstream> usr/lib/systemd/system/systemd-vmspawn@.service
usr/bin/machinectl
@@ -17,6 +18,7 @@ usr/lib/systemd/systemd-nsresourcework
usr/lib/systemd/systemd-portabled
usr/lib/systemd/systemd-pull
usr/lib/systemd/systemd-sysupdate
+<pkg.systemd.upstream> usr/lib/systemd/systemd-sysupdated
<pkg.systemd.upstream> usr/lib/systemd/system-generators/systemd-import-generator
<pkg.systemd.upstream> usr/lib/systemd/system/sockets.target.wants/systemd-importd.socket
usr/lib/systemd/system/systemd-nspawn@.service
@@ -30,12 +32,14 @@ usr/lib/systemd/system/systemd-sysupdate-reboot.service
usr/lib/systemd/system/systemd-sysupdate-reboot.timer
usr/lib/systemd/system/systemd-sysupdate.service
usr/lib/systemd/system/systemd-sysupdate.timer
+<pkg.systemd.upstream> usr/lib/systemd/system/systemd-sysupdated.service
usr/lib/systemd/system/var-lib-machines.mount
usr/lib/systemd/system/machines.target
usr/lib/systemd/system/*.target.wants/var-lib-machines.mount
usr/lib/systemd/system/dbus-org.freedesktop.import1.service
usr/lib/systemd/system/dbus-org.freedesktop.machine1.service
usr/lib/systemd/system/dbus-org.freedesktop.portable1.service
+<pkg.systemd.upstream> usr/lib/systemd/system/dbus-org.freedesktop.sysupdate1.service
usr/bin/systemd-dissect
usr/bin/systemd-nspawn
usr/lib/tmpfiles.d/portables.conf
@@ -44,13 +48,16 @@ usr/sbin/mount.ddi
usr/share/dbus-1/system.d/org.freedesktop.import1.conf
usr/share/dbus-1/system.d/org.freedesktop.machine1.conf
usr/share/dbus-1/system.d/org.freedesktop.portable1.conf
+<pkg.systemd.upstream> usr/share/dbus-1/system.d/org.freedesktop.sysupdate1.conf
usr/share/dbus-1/system-services/org.freedesktop.import1.service
usr/share/dbus-1/system-services/org.freedesktop.machine1.service
usr/share/dbus-1/system-services/org.freedesktop.portable1.service
+<pkg.systemd.upstream> usr/share/dbus-1/system-services/org.freedesktop.sysupdate1.service
usr/share/polkit-1/actions/io.systemd.mount-file-system.policy
usr/share/polkit-1/actions/org.freedesktop.import1.policy
usr/share/polkit-1/actions/org.freedesktop.machine1.policy
usr/share/polkit-1/actions/org.freedesktop.portable1.policy
+<pkg.systemd.upstream> usr/share/polkit-1/actions/org.freedesktop.sysupdate1.policy
usr/share/zsh/vendor-completions/_systemd-nspawn
usr/share/zsh/vendor-completions/_sd_machines
usr/share/zsh/vendor-completions/_machinectl
diff --git a/debian/systemd-container.manpages b/debian/systemd-container.manpages
index 8bf5780..8eecac9 100755
--- a/debian/systemd-container.manpages
+++ b/debian/systemd-container.manpages
@@ -1,9 +1,11 @@
#!/usr/bin/dh-exec
debian/tmp/usr/share/man/man1/importctl.1
+<pkg.systemd.upstream> debian/tmp/usr/share/man/man1/updatectl.1
<pkg.systemd.upstream> debian/tmp/usr/share/man/man1/systemd-vmspawn.1
debian/tmp/usr/share/man/man1/mount.ddi.1
debian/tmp/usr/share/man/man1/systemd-nspawn.1
debian/tmp/usr/share/man/man5/org.freedesktop.import1.5
+<pkg.systemd.upstream> debian/tmp/usr/share/man/man5/org.freedesktop.sysupdate1.5
debian/tmp/usr/share/man/man5/systemd.nspawn.5
debian/tmp/usr/share/man/man5/sysupdate.d.5
debian/tmp/usr/share/man/man1/machinectl.1
@@ -25,3 +27,5 @@ debian/tmp/usr/share/man/man8/systemd-sysupdate-reboot.service.8
debian/tmp/usr/share/man/man8/systemd-sysupdate-reboot.timer.8
debian/tmp/usr/share/man/man8/systemd-sysupdate.service.8
debian/tmp/usr/share/man/man8/systemd-sysupdate.timer.8
+<pkg.systemd.upstream> debian/tmp/usr/share/man/man8/systemd-sysupdated.8
+<pkg.systemd.upstream> debian/tmp/usr/share/man/man8/systemd-sysupdated.service.8
diff --git a/debian/systemd.install b/debian/systemd.install
index d240822..91c72cf 100755
--- a/debian/systemd.install
+++ b/debian/systemd.install
@@ -140,7 +140,6 @@ usr/lib/systemd/systemd-sysroot-fstab-check
usr/lib/systemd/systemd-timedated
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/systemd-tpm2-setup
usr/lib/systemd/systemd-update-done
-usr/lib/systemd/systemd-update-utmp
usr/lib/systemd/systemd-user-runtime-dir
usr/lib/systemd/systemd-user-sessions
usr/lib/systemd/systemd-volatile-root
@@ -166,7 +165,6 @@ usr/lib/systemd/system/getty-pre.target
usr/lib/systemd/system/getty@.service
usr/lib/systemd/system/getty.target
usr/lib/systemd/system/graphical.target
-usr/lib/systemd/system/graphical.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/halt.target
usr/lib/systemd/system/hibernate.target
usr/lib/systemd/system/hybrid-sleep.target
@@ -195,7 +193,6 @@ usr/lib/systemd/system/multi-user.target
usr/lib/systemd/system/multi-user.target.wants/getty.target
usr/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
usr/lib/systemd/system/multi-user.target.wants/systemd-logind.service
-usr/lib/systemd/system/multi-user.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/multi-user.target.wants/systemd-user-sessions.service
usr/lib/systemd/system/network-online.target
usr/lib/systemd/system/network-pre.target
@@ -215,7 +212,6 @@ usr/lib/systemd/system/remote-fs-pre.target
usr/lib/systemd/system/remote-fs.target
usr/lib/systemd/system/rescue.service
usr/lib/systemd/system/rescue.target
-usr/lib/systemd/system/rescue.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/rpcbind.target
usr/lib/systemd/system/runlevel0.target
usr/lib/systemd/system/runlevel1.target
@@ -237,7 +233,7 @@ usr/lib/systemd/system/sockets.target.wants/systemd-hostnamed.socket
usr/lib/systemd/system/sockets.target.wants/systemd-journald-dev-log.socket
usr/lib/systemd/system/sockets.target.wants/systemd-journald.socket
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sockets.target.wants/systemd-pcrextend.socket
-[amd64 i386 arm64 armhf riscv64] usr/lib/systemd/system/sockets.target.wants/systemd-pcrlock.socket
+[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sockets.target.wants/systemd-pcrlock.socket
usr/lib/systemd/system/sockets.target.wants/systemd-sysext.socket
usr/lib/systemd/system/soft-reboot.target
usr/lib/systemd/system/sound.target
@@ -278,7 +274,6 @@ usr/lib/systemd/system/sysinit.target.wants/systemd-tmpfiles-setup.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sysinit.target.wants/systemd-tpm2-setup-early.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sysinit.target.wants/systemd-tpm2-setup.service
usr/lib/systemd/system/sysinit.target.wants/systemd-update-done.service
-usr/lib/systemd/system/sysinit.target.wants/systemd-update-utmp.service
usr/lib/systemd/system/sys-kernel-config.mount
usr/lib/systemd/system/sys-kernel-debug.mount
usr/lib/systemd/system/sys-kernel-tracing.mount
@@ -332,8 +327,8 @@ usr/lib/systemd/system/systemd-network-generator.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrextend.socket
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrfs-root.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrfs@.service
-[amd64 i386 arm64 armhf riscv64] usr/lib/systemd/system/systemd-pcrlock.socket
-[amd64 i386 arm64 armhf riscv64] usr/lib/systemd/system/systemd-pcrlock@.service
+[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrlock.socket
+[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrlock@.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrlock-file-system.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrlock-firmware-code.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-pcrlock-firmware-config.service
@@ -371,8 +366,6 @@ usr/lib/systemd/system/systemd-tmpfiles-setup.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-tpm2-setup-early.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-tpm2-setup.service
usr/lib/systemd/system/systemd-update-done.service
-usr/lib/systemd/system/systemd-update-utmp-runlevel.service
-usr/lib/systemd/system/systemd-update-utmp.service
usr/lib/systemd/system/systemd-user-sessions.service
usr/lib/systemd/system/systemd-volatile-root.service
usr/lib/systemd/system/system-update-cleanup.service
diff --git a/debian/systemd.manpages b/debian/systemd.manpages
index e6bb5a9..f2f2a27 100755
--- a/debian/systemd.manpages
+++ b/debian/systemd.manpages
@@ -23,8 +23,7 @@ debian/tmp/usr/share/man/man1/systemd-firstboot.service.1
debian/tmp/usr/share/man/man1/systemd-id128.1
debian/tmp/usr/share/man/man1/systemd-inhibit.1
debian/tmp/usr/share/man/man1/systemd-machine-id-setup.1
-[amd64 i386 arm64 armhf riscv64] <!stage1 !pkg.systemd.upstream> debian/tmp/usr/share/man/man1/systemd-measure.1
-debian/tmp/usr/share/man/man1/systemd-measure.1
+<!stage1> debian/tmp/usr/share/man/man1/systemd-measure.1
debian/tmp/usr/share/man/man1/systemd-mount.1
debian/tmp/usr/share/man/man1/systemd-notify.1
debian/tmp/usr/share/man/man1/systemd-path.1
@@ -254,9 +253,6 @@ debian/tmp/usr/share/man/man8/systemd-tpm2-generator.8
debian/tmp/usr/share/man/man8/systemd-udev-settle.service.8
debian/tmp/usr/share/man/man8/systemd-update-done.8
debian/tmp/usr/share/man/man8/systemd-update-done.service.8
-debian/tmp/usr/share/man/man8/systemd-update-utmp.8
-debian/tmp/usr/share/man/man8/systemd-update-utmp-runlevel.service.8
-debian/tmp/usr/share/man/man8/systemd-update-utmp.service.8
debian/tmp/usr/share/man/man8/systemd-user-sessions.8
debian/tmp/usr/share/man/man8/systemd-user-sessions.service.8
debian/tmp/usr/share/man/man8/systemd-volatile-root.8
diff --git a/debian/tests/upstream b/debian/tests/upstream
index 1ca3df3..d2c1420 100755
--- a/debian/tests/upstream
+++ b/debian/tests/upstream
@@ -92,17 +92,10 @@ Incremental=no
EOF
# reprepro is unhappy about non-existing directories
-package_directories=""
if [ -d "${AUTOPKGTEST_TMP}/../binaries" ]; then
- package_directories="${AUTOPKGTEST_TMP}/../binaries,$package_directories"
-fi
-if [ -d /var/cache/apt/archives/ ]; then
- package_directories="/var/cache/apt/archives/,$package_directories"
-fi
-if [ -n "$package_directories" ]; then
tee -a mkosi.local.conf <<EOF
[Content]
-PackageDirectories=$package_directories
+PackageDirectories=${AUTOPKGTEST_TMP}/../binaries
EOF
fi