summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch8
-rw-r--r--debian/patches/debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch2
-rw-r--r--debian/patches/debian/Skip-flaky-test_resolved_domain_restricted_dns-in-network.patch24
-rw-r--r--debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch4
-rw-r--r--debian/patches/series1
5 files changed, 7 insertions, 32 deletions
diff --git a/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch b/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
index 1c839bd..39166cb 100644
--- a/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
+++ b/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
@@ -16,7 +16,7 @@ Closes: #981407
3 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/src/core/load-fragment.c b/src/core/load-fragment.c
-index f442bd8..a92f683 100644
+index 0baf08e..8eec584 100644
--- a/src/core/load-fragment.c
+++ b/src/core/load-fragment.c
@@ -544,6 +544,7 @@ static int patch_var_run(
@@ -51,10 +51,10 @@ index 4485e2e..d0e8ed8 100644
"%s Automatically generating a unit file for compatibility. Please update package to include a native systemd unit file, in order to make it safe, robust and future-proof. "
"%s This compatibility logic is deprecated, expect removal soon. %s",
diff --git a/src/tmpfiles/tmpfiles.c b/src/tmpfiles/tmpfiles.c
-index 230ec09..d513d40 100644
+index 4919cb7..be24b04 100644
--- a/src/tmpfiles/tmpfiles.c
+++ b/src/tmpfiles/tmpfiles.c
-@@ -3266,6 +3266,7 @@ static int specifier_expansion_from_arg(const Specifier *specifier_table, Item *
+@@ -3257,6 +3257,7 @@ static int specifier_expansion_from_arg(const Specifier *specifier_table, Item *
static int patch_var_run(const char *fname, unsigned line, char **path) {
const char *k;
char *n;
@@ -62,7 +62,7 @@ index 230ec09..d513d40 100644
assert(path);
assert(*path);
-@@ -3291,7 +3292,8 @@ static int patch_var_run(const char *fname, unsigned line, char **path) {
+@@ -3282,7 +3283,8 @@ static int patch_var_run(const char *fname, unsigned line, char **path) {
/* Also log about this briefly. We do so at LOG_NOTICE level, as we fixed up the situation automatically, hence
* there's no immediate need for action by the user. However, in the interest of making things less confusing
* to the user, let's still inform the user that these snippets should really be updated. */
diff --git a/debian/patches/debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch b/debian/patches/debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch
index 267c2b4..3378f82 100644
--- a/debian/patches/debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch
+++ b/debian/patches/debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch
@@ -19,7 +19,7 @@ Bug-Debian: https://bugs.debian.org/815020
2 files changed, 1 insertion(+), 19 deletions(-)
diff --git a/src/core/main.c b/src/core/main.c
-index 3f71cc0..876c7d5 100644
+index 1ed968d..758325d 100644
--- a/src/core/main.c
+++ b/src/core/main.c
@@ -1653,22 +1653,6 @@ static void cmdline_take_random_seed(void) {
diff --git a/debian/patches/debian/Skip-flaky-test_resolved_domain_restricted_dns-in-network.patch b/debian/patches/debian/Skip-flaky-test_resolved_domain_restricted_dns-in-network.patch
deleted file mode 100644
index a57191d..0000000
--- a/debian/patches/debian/Skip-flaky-test_resolved_domain_restricted_dns-in-network.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Michael Biebl <biebl@debian.org>
-Date: Tue, 13 Dec 2022 00:32:17 +0100
-Subject: Skip flaky test_resolved_domain_restricted_dns in networkd-test.py
-
-This test is part of DnsmasqClientTest and does not work reliably under
-LXC/debci, so skip it for the time being.
-
-Closes: #1025908
----
- test/networkd-test.py | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/test/networkd-test.py b/test/networkd-test.py
-index 512137c..1bf1538 100755
---- a/test/networkd-test.py
-+++ b/test/networkd-test.py
-@@ -639,6 +639,7 @@ class DnsmasqClientTest(ClientTestBase, unittest.TestCase):
- with open(path) as f:
- sys.stdout.write('\n\n---- {} ----\n{}\n------\n\n'.format(os.path.basename(path), f.read()))
-
-+ @unittest.skip("test is flaky: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1025908")
- def test_resolved_domain_restricted_dns(self):
- '''resolved: domain-restricted DNS servers'''
-
diff --git a/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch b/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
index 7ec4439..655dd27 100644
--- a/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
+++ b/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
@@ -241,10 +241,10 @@ index 0000000..b7ad58d
+
+</refentry>
diff --git a/meson.build b/meson.build
-index f1f4e7e..24f5bd2 100644
+index 554765b..0fce0fd 100644
--- a/meson.build
+++ b/meson.build
-@@ -2152,6 +2152,7 @@ subdir('src/environment-d-generator')
+@@ -2154,6 +2154,7 @@ subdir('src/environment-d-generator')
subdir('src/escape')
subdir('src/firstboot')
subdir('src/fsck')
diff --git a/debian/patches/series b/debian/patches/series
index 8d381dd..4616402 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,7 +5,6 @@ debian/Skip-filesystem-check-if-already-done-by-the-initram.patch
debian/Revert-core-set-RLIMIT_CORE-to-unlimited-by-default.patch
debian/systemctl-do-not-shutdown-immediately-on-scheduled-shutdo.patch
debian/Downgrade-a-couple-of-warnings-to-debug.patch
-debian/Skip-flaky-test_resolved_domain_restricted_dns-in-network.patch
debian/localectl-disable-keymap-support.patch
progress-linux/0001-agetty-nohostname.patch
progress-linux/0002-proc-hidepid.patch