summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 16 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index fe3fd47..d088b61 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,13 @@ export LC_ALL = C.UTF-8
include /usr/share/dpkg/default.mk
include /usr/share/debhelper/dh_package_notes/package-notes.mk
+ifeq (amd64,$(DEB_HOST_ARCH))
+export DEB_HOST_ARCH_EFI=x64
+else ifeq (arm64,$(DEB_HOST_ARCH))
+export DEB_HOST_ARCH_EFI=aa64
+endif
+
+
ifeq ($(DEB_VENDOR),Ubuntu)
DEFAULT_NTP_SERVERS = ntp.ubuntu.com
SUPPORT_URL = http://www.ubuntu.com/support
@@ -268,9 +275,8 @@ execute_before_dh_install:
fi
# remove obsolete compat symlink
rm -f debian/tmp/usr/bin/systemd-resolve
- # we don't want repart and shutdown standalone binaries for now
+ # we don't want the repart standalone binary for now
rm -f debian/tmp/usr/bin/systemd-repart.standalone
- rm -f debian/tmp/usr/lib/systemd/systemd-shutdown.standalone
# files shipped by cryptsetup
ifeq (, $(filter stage1, $(DEB_BUILD_PROFILES)))
rm -f debian/tmp/usr/share/man/man5/crypttab.5
@@ -294,6 +300,14 @@ else
install -D --mode=644 debian/extra/resolved.conf.d/cache-no-negative.conf debian/systemd-resolved/usr/lib/systemd/resolved.conf.d/cache-no-negative.conf
endif
+ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
+ifeq ($(DEB_VENDOR),Debian)
+ifneq ($(DEB_HOST_ARCH_EFI),)
+ debian/extra/gen-signing-template $(DEB_VERSION) $(DEB_HOST_ARCH) $(DEB_HOST_ARCH_EFI)
+endif
+endif
+endif
+
# Remove empty directories from /usr/lib.
# Those are not strictly needed and can trigger piuparts errors due to
# accidential directory removal by dpkg on merged-/usr systems.