summaryrefslogtreecommitdiffstats
path: root/debian/signing-template/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/signing-template/rules')
-rwxr-xr-xdebian/signing-template/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/signing-template/rules b/debian/signing-template/rules
new file mode 100755
index 0000000..0887e3e
--- /dev/null
+++ b/debian/signing-template/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/default.mk
+
+BINARY = systemd-boot${DEB_HOST_ARCH_EFI}.efi
+INSTALLED = usr/lib/systemd/boot/efi/$(BINARY)
+SIGNATURE = debian/signatures/systemd-boot-efi/$(INSTALLED).sig
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ cp /$(INSTALLED) $(BINARY)
+ sbattach --attach $(SIGNATURE) $(BINARY)
+ mv $(BINARY) $(BINARY).signed
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v${DEB_VERSION}