summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rwxr-xr-xdebian/extra/checkout-upstream10
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/test-fix-D-Bus-policy-override-for-TEST-73-LOCALE.patch25
-rwxr-xr-xdebian/tests/upstream5
5 files changed, 23 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index 372caeb..a1ef3cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+systemd (256.5-1) unstable; urgency=medium
+
+ * New upstream version 256.5
+ * Drop patch merged upstream
+ * autopkgtest: skip TEST-64-UDEV-STORAGE due to qemu crash. This tests
+ randomly causes qemu to crash, making it very flaky, skip it
+ downstream
+
+ -- Luca Boccassi <bluca@debian.org> Thu, 15 Aug 2024 22:00:36 +0100
+
systemd (256.4-3~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/extra/checkout-upstream b/debian/extra/checkout-upstream
index 025b1df..7981d7b 100755
--- a/debian/extra/checkout-upstream
+++ b/debian/extra/checkout-upstream
@@ -49,7 +49,12 @@ mkdir -p debian/tmp
$CO
git config user.email "$DUMMY_USER_EMAIL"
git config user.name "$DUMMY_USER_NAME"
- if [ -n "${UPSTREAM_PULL_REQUEST:-}" ] && [ "${UPSTREAM_REPO}" != "https://github.com/systemd/systemd-stable.git" ]; then
+ if [ -f meson.version ]; then
+ UPSTREAM_VER=$(cat meson.version)
+ else
+ UPSTREAM_VER=$(git describe | sed 's/^v//;s/-/./g')
+ fi
+ if [ -n "${UPSTREAM_PULL_REQUEST:-}" ] && [ "${UPSTREAM_REPO}" != "https://github.com/systemd/systemd-stable.git" ] && ! echo "$UPSTREAM_VER" | grep -q '\.'; then
git rebase main || git rebase --abort
fi
)
@@ -63,7 +68,8 @@ fi
# build dependencies it is already too late, but this is mostly relevant for the dh_install files and
# the tests.
if [ -d .git ] && echo "$UPSTREAM_VER" | grep -q '\.'; then
- git checkout "ci/v${UPSTREAM_VER%%.*}-stable"
+ rm -rf .pc
+ git reset --hard "origin/ci/v${UPSTREAM_VER%%.*}-stable"
fi
if [ -n "${KEEP_DEBIAN_PATCHES:-}" ]; then
diff --git a/debian/patches/series b/debian/patches/series
index af6e44e..a00f68b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
-test-fix-D-Bus-policy-override-for-TEST-73-LOCALE.patch
progress-linux/0001-agetty-nohostname.patch
progress-linux/0002-proc-hidepid.patch
progress-linux/0003-logind-noautovts.patch
diff --git a/debian/patches/test-fix-D-Bus-policy-override-for-TEST-73-LOCALE.patch b/debian/patches/test-fix-D-Bus-policy-override-for-TEST-73-LOCALE.patch
deleted file mode 100644
index 5cf6e44..0000000
--- a/debian/patches/test-fix-D-Bus-policy-override-for-TEST-73-LOCALE.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Author: Luca Boccassi <bluca@debian.org>
-Forwarded: yes
-Description: test: fix D-Bus policy override for TEST-73-LOCALE
- We don't need to allow non-root, and the policy needs to specify destination
- and interface too, to narrow it down
---- a/test/units/TEST-73-LOCALE.sh
-+++ b/test/units/TEST-73-LOCALE.sh
-@@ -666,14 +666,9 @@
- "https://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
- <busconfig>
- <policy user="root">
-- <allow send_member="SetLocale"/>
-- <allow send_member="SetVConsoleKeyboard"/>
-- <allow send_member="SetX11Keyboard"/>
-- </policy>
-- <policy context="default">
-- <allow send_member="SetLocale"/>
-- <allow send_member="SetVConsoleKeyboard"/>
-- <allow send_member="SetX11Keyboard"/>
-+ <allow send_destination="org.freedesktop.locale1" send_interface="org.freedesktop.locale1" send_member="SetLocale"/>
-+ <allow send_destination="org.freedesktop.locale1" send_interface="org.freedesktop.locale1" send_member="SetVConsoleKeyboard"/>
-+ <allow send_destination="org.freedesktop.locale1" send_interface="org.freedesktop.locale1" send_member="SetX11Keyboard"/>
- </policy>
- </busconfig>
- EOF
diff --git a/debian/tests/upstream b/debian/tests/upstream
index 7d81f29..1ca3df3 100755
--- a/debian/tests/upstream
+++ b/debian/tests/upstream
@@ -123,6 +123,11 @@ if [ ! -e /dev/kvm ]; then
export TEST_NO_KVM=1
fi
+# This test causes qemu to crash too often
+if [ "${DEB_BUILD_PROFILES#*pkg.systemd.upstream*}" = "${DEB_BUILD_PROFILES:-}" ]; then
+ export TEST_SKIP=TEST-64-UDEV-STORAGE
+fi
+
export ARTIFACT_DIRECTORY="$AUTOPKGTEST_ARTIFACTS"
export PATH="${mkosi_tree}/bin:$PATH"
export TEST_SAVE_JOURNAL=fail