summaryrefslogtreecommitdiffstats
path: root/src/binfmt/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/binfmt/meson.build')
-rw-r--r--src/binfmt/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/binfmt/meson.build b/src/binfmt/meson.build
new file mode 100644
index 0000000..4496340
--- /dev/null
+++ b/src/binfmt/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-binfmt',
+ 'public' : true,
+ 'conditions' : ['ENABLE_BINFMT'],
+ 'sources' : files('binfmt.c'),
+ },
+]
+
+if conf.get('ENABLE_BINFMT') == 1
+ install_emptydir(binfmtdir)
+ if install_sysconfdir
+ install_emptydir(sysconfdir / 'binfmt.d')
+ endif
+endif