summaryrefslogtreecommitdiffstats
path: root/src/firstboot/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/firstboot/meson.build')
-rw-r--r--src/firstboot/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/firstboot/meson.build b/src/firstboot/meson.build
new file mode 100644
index 0000000..28c1d27
--- /dev/null
+++ b/src/firstboot/meson.build
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ executable_template + {
+ 'name' : 'systemd-firstboot',
+ 'public' : true,
+ 'conditions' : ['ENABLE_FIRSTBOOT'],
+ 'sources' : files('firstboot.c'),
+ 'dependencies' : libcrypt,
+ },
+]