summaryrefslogtreecommitdiffstats
path: root/src/run/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/run/meson.build')
-rw-r--r--src/run/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/run/meson.build b/src/run/meson.build
index 597a25a..221b441 100644
--- a/src/run/meson.build
+++ b/src/run/meson.build
@@ -7,3 +7,17 @@ executables += [
'sources' : files('run.c'),
},
]
+
+install_emptydir(bindir)
+
+meson.add_install_script(sh, '-c',
+ ln_s.format(bindir / 'systemd-run',
+ bindir / 'run0'))
+
+custom_target(
+ 'systemd-run0',
+ input : 'systemd-run0.in',
+ output : 'systemd-run0',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : pamconfdir != 'no',
+ install_dir : pamconfdir)