summaryrefslogtreecommitdiffstats
path: root/src/sleep
diff options
context:
space:
mode:
Diffstat (limited to 'src/sleep')
-rw-r--r--src/sleep/battery-capacity.c384
-rw-r--r--src/sleep/battery-capacity.h18
-rw-r--r--src/sleep/meson.build22
-rw-r--r--src/sleep/sleep.c651
-rw-r--r--src/sleep/sleep.conf27
-rw-r--r--src/sleep/test-battery-capacity.c45
6 files changed, 1147 insertions, 0 deletions
diff --git a/src/sleep/battery-capacity.c b/src/sleep/battery-capacity.c
new file mode 100644
index 0000000..62a0746
--- /dev/null
+++ b/src/sleep/battery-capacity.c
@@ -0,0 +1,384 @@
+/* SPDX-License-Identifier: LGPL-2.1-or-later */
+
+#include "sd-device.h"
+
+#include "battery-capacity.h"
+#include "battery-util.h"
+#include "device-private.h"
+#include "device-util.h"
+#include "extract-word.h"
+#include "fd-util.h"
+#include "fileio.h"
+#include "hexdecoct.h"
+#include "id128-util.h"
+#include "parse-util.h"
+#include "siphash24.h"
+
+#define DISCHARGE_RATE_FILEPATH "/var/lib/systemd/sleep/battery_discharge_percentage_rate_per_hour"
+#define BATTERY_DISCHARGE_RATE_HASH_KEY SD_ID128_MAKE(5f,9a,20,18,38,76,46,07,8d,36,58,0b,bb,c4,e0,63)
+
+static void *CAPACITY_TO_PTR(int capacity) {
+ assert(capacity >= 0);
+ assert(capacity <= 100);
+ return INT_TO_PTR(capacity + 1);
+}
+
+static int PTR_TO_CAPACITY(void *p) {
+ int capacity = PTR_TO_INT(p) - 1;
+ assert(capacity >= 0);
+ assert(capacity <= 100);
+ return capacity;
+}
+
+static int siphash24_compress_device_sysattr(
+ sd_device *dev,
+ const char *attr,
+ struct siphash *state) {
+
+ const char *x;
+ int r;
+
+ assert(dev);
+ assert(attr);
+ assert(state);
+
+ r = sd_device_get_sysattr_value(dev, attr, &x);
+ if (r < 0)
+ return log_device_debug_errno(dev, r, "Failed to read '%s' attribute: %m", attr);
+
+ if (!isempty(x))
+ siphash24_compress_string(x, state);
+
+ return 0;
+}
+
+static int siphash24_compress_id128(
+ int (*getter)(sd_id128_t *ret),
+ const char *name,
+ struct siphash *state) {
+
+ sd_id128_t id;
+ int r;
+
+ assert(getter);
+ assert(name);
+ assert(state);
+
+ r = getter(&id);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to get %s ID: %m", name);
+
+ siphash24_compress(&id, sizeof(sd_id128_t), state);
+ return 0;
+}
+
+/* Read system and battery identifier from specific location and generate hash of it */
+static uint64_t system_battery_identifier_hash(sd_device *dev) {
+ struct siphash state;
+
+ assert(dev);
+
+ siphash24_init(&state, BATTERY_DISCHARGE_RATE_HASH_KEY.bytes);
+
+ (void) siphash24_compress_device_sysattr(dev, "manufacturer", &state);
+ (void) siphash24_compress_device_sysattr(dev, "model_name", &state);
+ (void) siphash24_compress_device_sysattr(dev, "serial_number", &state);
+ (void) siphash24_compress_id128(sd_id128_get_machine, "machine", &state);
+ (void) siphash24_compress_id128(id128_get_product, "product", &state);
+
+ return siphash24_finalize(&state);
+}
+
+/* Return success if battery percentage discharge rate per hour is in the range 1–199 */
+static bool battery_discharge_rate_is_valid(int battery_discharge_rate) {
+ return battery_discharge_rate > 0 && battery_discharge_rate < 200;
+}
+
+/* Battery percentage discharge rate per hour is read from specific file. It is stored along with system
+ * and battery identifier hash to maintain the integrity of discharge rate value */
+static int get_battery_discharge_rate(sd_device *dev, int *ret) {
+ _cleanup_fclose_ FILE *f = NULL;
+ uint64_t current_hash_id;
+ const char *p;
+ int r;
+
+ assert(dev);
+ assert(ret);
+
+ f = fopen(DISCHARGE_RATE_FILEPATH, "re");
+ if (!f)
+ return log_debug_errno(errno, "Failed to read discharge rate from " DISCHARGE_RATE_FILEPATH ": %m");
+
+ current_hash_id = system_battery_identifier_hash(dev);
+
+ for (;;) {
+ _cleanup_free_ char *stored_hash_id = NULL, *stored_discharge_rate = NULL, *line = NULL;
+ uint64_t hash_id;
+ int discharge_rate;
+
+ r = read_line(f, LONG_LINE_MAX, &line);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to read discharge rate from " DISCHARGE_RATE_FILEPATH ": %m");
+ if (r == 0)
+ break;
+
+ p = line;
+ r = extract_many_words(&p, NULL, 0, &stored_hash_id, &stored_discharge_rate, NULL);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to parse hash_id and discharge_rate read from " DISCHARGE_RATE_FILEPATH ": %m");
+ if (r != 2)
+ return log_debug_errno(SYNTHETIC_ERRNO(EINVAL), "Invalid number of items fetched from " DISCHARGE_RATE_FILEPATH);
+
+ r = safe_atou64(stored_hash_id, &hash_id);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to parse hash ID read from " DISCHARGE_RATE_FILEPATH " location: %m");
+
+ if (current_hash_id != hash_id)
+ /* matching device not found, move to next line */
+ continue;
+
+ r = safe_atoi(stored_discharge_rate, &discharge_rate);
+ if (r < 0)
+ return log_device_debug_errno(dev, r, "Failed to parse discharge rate read from " DISCHARGE_RATE_FILEPATH ": %m");
+
+ if (!battery_discharge_rate_is_valid(discharge_rate))
+ return log_device_debug_errno(dev, SYNTHETIC_ERRNO(ERANGE), "Invalid battery discharge percentage rate per hour: %m");
+
+ *ret = discharge_rate;
+ return 0; /* matching device found, exit iteration */
+ }
+
+ return -ENOENT;
+}
+
+/* Write battery percentage discharge rate per hour along with system and battery identifier hash to file */
+static int put_battery_discharge_rate(int estimated_battery_discharge_rate, uint64_t system_hash_id, bool trunc) {
+ int r;
+
+ if (!battery_discharge_rate_is_valid(estimated_battery_discharge_rate))
+ return log_debug_errno(SYNTHETIC_ERRNO(ERANGE),
+ "Invalid battery discharge rate %d%% per hour: %m",
+ estimated_battery_discharge_rate);
+
+ r = write_string_filef(
+ DISCHARGE_RATE_FILEPATH,
+ WRITE_STRING_FILE_CREATE | WRITE_STRING_FILE_MKDIR_0755 | (trunc ? WRITE_STRING_FILE_TRUNCATE : 0),
+ "%"PRIu64" %d",
+ system_hash_id,
+ estimated_battery_discharge_rate);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to update %s: %m", DISCHARGE_RATE_FILEPATH);
+
+ log_debug("Estimated discharge rate %d%% per hour successfully saved to %s", estimated_battery_discharge_rate, DISCHARGE_RATE_FILEPATH);
+
+ return 0;
+}
+
+/* Store current capacity of each battery before suspension and timestamp */
+int fetch_batteries_capacity_by_name(Hashmap **ret) {
+ _cleanup_(sd_device_enumerator_unrefp) sd_device_enumerator *e = NULL;
+ _cleanup_hashmap_free_ Hashmap *batteries_capacity_by_name = NULL;
+ int r;
+
+ assert(ret);
+
+ batteries_capacity_by_name = hashmap_new(&string_hash_ops_free);
+ if (!batteries_capacity_by_name)
+ return log_oom_debug();
+
+ r = battery_enumerator_new(&e);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to initialize battery enumerator: %m");
+
+ FOREACH_DEVICE(e, dev) {
+ _cleanup_free_ char *battery_name_copy = NULL;
+ const char *battery_name;
+ int battery_capacity;
+
+ battery_capacity = r = battery_read_capacity_percentage(dev);
+ if (r < 0)
+ continue;
+
+ r = sd_device_get_property_value(dev, "POWER_SUPPLY_NAME", &battery_name);
+ if (r < 0) {
+ log_device_debug_errno(dev, r, "Failed to get POWER_SUPPLY_NAME property, ignoring: %m");
+ continue;
+ }
+
+ battery_name_copy = strdup(battery_name);
+ if (!battery_name_copy)
+ return log_oom_debug();
+
+ r = hashmap_put(batteries_capacity_by_name, battery_name_copy, CAPACITY_TO_PTR(battery_capacity));
+ if (r < 0)
+ return log_device_debug_errno(dev, r, "Failed to store battery capacity: %m");
+
+ TAKE_PTR(battery_name_copy);
+ }
+
+ *ret = TAKE_PTR(batteries_capacity_by_name);
+
+ return 0;
+}
+
+int get_capacity_by_name(Hashmap *capacities_by_name, const char *name) {
+ void *p;
+
+ assert(capacities_by_name);
+ assert(name);
+
+ p = hashmap_get(capacities_by_name, name);
+ if (!p)
+ return -ENOENT;
+
+ return PTR_TO_CAPACITY(p);
+}
+
+/* Estimate battery discharge rate using stored previous and current capacity over timestamp difference */
+int estimate_battery_discharge_rate_per_hour(
+ Hashmap *last_capacity,
+ Hashmap *current_capacity,
+ usec_t before_timestamp,
+ usec_t after_timestamp) {
+
+ _cleanup_(sd_device_enumerator_unrefp) sd_device_enumerator *e = NULL;
+ bool trunc = true;
+ int r;
+
+ assert(last_capacity);
+ assert(current_capacity);
+ assert(before_timestamp < after_timestamp);
+
+ r = battery_enumerator_new(&e);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to initialize battery enumerator: %m");
+
+ FOREACH_DEVICE(e, dev) {
+ int battery_last_capacity, battery_current_capacity, battery_discharge_rate;
+ const char *battery_name;
+ uint64_t system_hash_id;
+
+ r = sd_device_get_property_value(dev, "POWER_SUPPLY_NAME", &battery_name);
+ if (r < 0) {
+ log_device_debug_errno(dev, r, "Failed to read battery name, ignoring: %m");
+ continue;
+ }
+
+ battery_last_capacity = get_capacity_by_name(last_capacity, battery_name);
+ if (battery_last_capacity < 0)
+ continue;
+
+ battery_current_capacity = get_capacity_by_name(current_capacity, battery_name);
+ if (battery_current_capacity < 0)
+ continue;
+
+ if (battery_current_capacity >= battery_last_capacity) {
+ log_device_debug(dev, "Battery was not discharged during suspension");
+ continue;
+ }
+
+ system_hash_id = system_battery_identifier_hash(dev);
+
+ log_device_debug(dev,
+ "%d%% was discharged in %s. Estimating discharge rate...",
+ battery_last_capacity - battery_current_capacity,
+ FORMAT_TIMESPAN(after_timestamp - before_timestamp, USEC_PER_SEC));
+
+ battery_discharge_rate = (battery_last_capacity - battery_current_capacity) * USEC_PER_HOUR / (after_timestamp - before_timestamp);
+ r = put_battery_discharge_rate(battery_discharge_rate, system_hash_id, trunc);
+ if (r < 0)
+ log_device_warning_errno(dev, r, "Failed to update battery discharge rate, ignoring: %m");
+ else
+ trunc = false;
+ }
+
+ return 0;
+}
+
+/* Calculate the suspend interval for each battery and then return their sum */
+int get_total_suspend_interval(Hashmap *last_capacity, usec_t *ret) {
+ _cleanup_(sd_device_enumerator_unrefp) sd_device_enumerator *e = NULL;
+ usec_t total_suspend_interval = 0;
+ int r;
+
+ assert(last_capacity);
+ assert(ret);
+
+ r = battery_enumerator_new(&e);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to initialize battery enumerator: %m");
+
+ FOREACH_DEVICE(e, dev) {
+ int battery_last_capacity, previous_discharge_rate = 0;
+ const char *battery_name;
+ usec_t suspend_interval;
+
+ r = sd_device_get_property_value(dev, "POWER_SUPPLY_NAME", &battery_name);
+ if (r < 0) {
+ log_device_debug_errno(dev, r, "Failed to read battery name, ignoring: %m");
+ continue;
+ }
+
+ battery_last_capacity = get_capacity_by_name(last_capacity, battery_name);
+ if (battery_last_capacity <= 0)
+ continue;
+
+ r = get_battery_discharge_rate(dev, &previous_discharge_rate);
+ if (r < 0) {
+ log_device_debug_errno(dev, r, "Failed to get discharge rate, ignoring: %m");
+ continue;
+ }
+
+ if (previous_discharge_rate == 0)
+ continue;
+
+ if (battery_last_capacity * 2 <= previous_discharge_rate) {
+ log_device_debug(dev, "Current battery capacity percentage too low compared to discharge rate");
+ continue;
+ }
+ suspend_interval = battery_last_capacity * USEC_PER_HOUR / previous_discharge_rate;
+
+ total_suspend_interval = usec_add(total_suspend_interval, suspend_interval);
+ }
+ /* Previous discharge rate is stored in per hour basis converted to usec.
+ * Subtract 30 minutes from the result to keep a buffer of 30 minutes before battery gets critical */
+ total_suspend_interval = usec_sub_unsigned(total_suspend_interval, 30 * USEC_PER_MINUTE);
+ if (total_suspend_interval == 0)
+ return -ENOENT;
+
+ *ret = total_suspend_interval;
+
+ return 0;
+}
+
+/* Return true if all batteries have acpi_btp support */
+int battery_trip_point_alarm_exists(void) {
+ _cleanup_(sd_device_enumerator_unrefp) sd_device_enumerator *e = NULL;
+ bool has_battery = false;
+ int r;
+
+ r = battery_enumerator_new(&e);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to initialize battery enumerator: %m");
+
+ FOREACH_DEVICE(e, dev) {
+ const char *alarm_attr;
+ int has_alarm;
+
+ has_battery = true;
+
+ r = sd_device_get_sysattr_value(dev, "alarm", &alarm_attr);
+ if (r < 0)
+ return log_device_debug_errno(dev, r, "Failed to read battery alarm attribute: %m");
+
+ r = safe_atoi(alarm_attr, &has_alarm);
+ if (r < 0)
+ return log_device_debug_errno(dev, r,
+ "Failed to parse battery alarm attribute '%s': %m",
+ alarm_attr);
+ if (has_alarm <= 0)
+ return false;
+ }
+
+ return has_battery;
+}
diff --git a/src/sleep/battery-capacity.h b/src/sleep/battery-capacity.h
new file mode 100644
index 0000000..df7b06c
--- /dev/null
+++ b/src/sleep/battery-capacity.h
@@ -0,0 +1,18 @@
+/* SPDX-License-Identifier: LGPL-2.1-or-later */
+#pragma once
+
+#include "hashmap.h"
+#include "time-util.h"
+
+int fetch_batteries_capacity_by_name(Hashmap **ret_current_capacity);
+int get_capacity_by_name(Hashmap *capacities_by_name, const char *name);
+
+int get_total_suspend_interval(Hashmap *last_capacity, usec_t *ret);
+
+int estimate_battery_discharge_rate_per_hour(
+ Hashmap *last_capacity,
+ Hashmap *current_capacity,
+ usec_t before_timestamp,
+ usec_t after_timestamp);
+
+int battery_trip_point_alarm_exists(void);
diff --git a/src/sleep/meson.build b/src/sleep/meson.build
new file mode 100644
index 0000000..fc0037e
--- /dev/null
+++ b/src/sleep/meson.build
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-sleep',
+ 'sources' : files(
+ 'sleep.c',
+ 'battery-capacity.c',
+ ),
+ },
+ test_template + {
+ 'sources' : files(
+ 'test-battery-capacity.c',
+ 'battery-capacity.c',
+ ),
+ },
+]
+
+if install_sysconfdir_samples
+ install_data('sleep.conf',
+ install_dir : pkgconfigfiledir)
+endif
diff --git a/src/sleep/sleep.c b/src/sleep/sleep.c
new file mode 100644
index 0000000..21062b2
--- /dev/null
+++ b/src/sleep/sleep.c
@@ -0,0 +1,651 @@
+/* SPDX-License-Identifier: LGPL-2.1-or-later */
+/***
+ Copyright © 2010-2017 Canonical
+ Copyright © 2018 Dell Inc.
+***/
+
+#include <errno.h>
+#include <fcntl.h>
+#include <getopt.h>
+#include <poll.h>
+#include <sys/timerfd.h>
+#include <sys/types.h>
+#include <sys/utsname.h>
+#include <unistd.h>
+
+#include "sd-bus.h"
+#include "sd-device.h"
+#include "sd-id128.h"
+#include "sd-messages.h"
+
+#include "battery-capacity.h"
+#include "battery-util.h"
+#include "build.h"
+#include "bus-error.h"
+#include "bus-locator.h"
+#include "bus-util.h"
+#include "constants.h"
+#include "devnum-util.h"
+#include "efivars.h"
+#include "exec-util.h"
+#include "fd-util.h"
+#include "fileio.h"
+#include "format-util.h"
+#include "hibernate-util.h"
+#include "id128-util.h"
+#include "io-util.h"
+#include "json.h"
+#include "log.h"
+#include "main-func.h"
+#include "os-util.h"
+#include "parse-util.h"
+#include "pretty-print.h"
+#include "sleep-config.h"
+#include "special.h"
+#include "stdio-util.h"
+#include "string-util.h"
+#include "strv.h"
+#include "time-util.h"
+
+#define DEFAULT_HIBERNATE_DELAY_USEC_NO_BATTERY (2 * USEC_PER_HOUR)
+
+static SleepOperation arg_operation = _SLEEP_OPERATION_INVALID;
+
+static int write_efi_hibernate_location(const HibernationDevice *hibernation_device, bool required) {
+ int log_level = required ? LOG_ERR : LOG_DEBUG;
+
+#if ENABLE_EFI
+ _cleanup_(json_variant_unrefp) JsonVariant *v = NULL;
+ _cleanup_free_ char *formatted = NULL, *id = NULL, *image_id = NULL,
+ *version_id = NULL, *image_version = NULL;
+ _cleanup_(sd_device_unrefp) sd_device *device = NULL;
+ const char *uuid_str;
+ sd_id128_t uuid;
+ struct utsname uts = {};
+ int r, log_level_ignore = required ? LOG_WARNING : LOG_DEBUG;
+
+ assert(hibernation_device);
+
+ if (!is_efi_boot())
+ return log_full_errno(log_level, SYNTHETIC_ERRNO(EOPNOTSUPP),
+ "Not an EFI boot, passing HibernateLocation via EFI variable is not possible.");
+
+ r = sd_device_new_from_devnum(&device, 'b', hibernation_device->devno);
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to create sd-device object for '%s': %m",
+ hibernation_device->path);
+
+ r = sd_device_get_property_value(device, "ID_FS_UUID", &uuid_str);
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to get filesystem UUID for device '%s': %m",
+ hibernation_device->path);
+
+ r = sd_id128_from_string(uuid_str, &uuid);
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to parse ID_FS_UUID '%s' for device '%s': %m",
+ uuid_str, hibernation_device->path);
+
+ if (uname(&uts) < 0)
+ log_full_errno(log_level_ignore, errno, "Failed to get kernel info, ignoring: %m");
+
+ r = parse_os_release(NULL,
+ "ID", &id,
+ "IMAGE_ID", &image_id,
+ "VERSION_ID", &version_id,
+ "IMAGE_VERSION", &image_version);
+ if (r < 0)
+ log_full_errno(log_level_ignore, r, "Failed to parse os-release, ignoring: %m");
+
+ r = json_build(&v, JSON_BUILD_OBJECT(
+ JSON_BUILD_PAIR_UUID("uuid", uuid),
+ JSON_BUILD_PAIR_UNSIGNED("offset", hibernation_device->offset),
+ JSON_BUILD_PAIR_CONDITION(!isempty(uts.release), "kernelVersion", JSON_BUILD_STRING(uts.release)),
+ JSON_BUILD_PAIR_CONDITION(id, "osReleaseId", JSON_BUILD_STRING(id)),
+ JSON_BUILD_PAIR_CONDITION(image_id, "osReleaseImageId", JSON_BUILD_STRING(image_id)),
+ JSON_BUILD_PAIR_CONDITION(version_id, "osReleaseVersionId", JSON_BUILD_STRING(version_id)),
+ JSON_BUILD_PAIR_CONDITION(image_version, "osReleaseImageVersion", JSON_BUILD_STRING(image_version))));
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to build JSON object: %m");
+
+ r = json_variant_format(v, 0, &formatted);
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to format JSON object: %m");
+
+ r = efi_set_variable_string(EFI_SYSTEMD_VARIABLE(HibernateLocation), formatted);
+ if (r < 0)
+ return log_full_errno(log_level, r, "Failed to set EFI variable HibernateLocation: %m");
+
+ log_debug("Set EFI variable HibernateLocation to '%s'.", formatted);
+ return 0;
+#else
+ return log_full_errno(log_level, SYNTHETIC_ERRNO(EOPNOTSUPP),
+ "EFI support not enabled, passing HibernateLocation via EFI variable is not possible.");
+#endif
+}
+
+static int write_state(int fd, char * const *states) {
+ int r = 0;
+
+ assert(fd >= 0);
+ assert(states);
+
+ STRV_FOREACH(state, states) {
+ _cleanup_fclose_ FILE *f = NULL;
+ int k;
+
+ k = fdopen_independent(fd, "we", &f);
+ if (k < 0)
+ return RET_GATHER(r, k);
+
+ k = write_string_stream(f, *state, WRITE_STRING_FILE_DISABLE_BUFFER);
+ if (k >= 0) {
+ log_debug("Using sleep state '%s'.", *state);
+ return 0;
+ }
+
+ RET_GATHER(r, log_debug_errno(k, "Failed to write '%s' to /sys/power/state: %m", *state));
+ }
+
+ return r;
+}
+
+static int write_mode(char * const *modes) {
+ int r = 0;
+
+ STRV_FOREACH(mode, modes) {
+ int k;
+
+ k = write_string_file("/sys/power/disk", *mode, WRITE_STRING_FILE_DISABLE_BUFFER);
+ if (k >= 0) {
+ log_debug("Using sleep disk mode '%s'.", *mode);
+ return 0;
+ }
+
+ RET_GATHER(r, log_debug_errno(k, "Failed to write '%s' to /sys/power/disk: %m", *mode));
+ }
+
+ return r;
+}
+
+static int lock_all_homes(void) {
+ _cleanup_(sd_bus_error_free) sd_bus_error error = SD_BUS_ERROR_NULL;
+ _cleanup_(sd_bus_message_unrefp) sd_bus_message *m = NULL;
+ _cleanup_(sd_bus_flush_close_unrefp) sd_bus *bus = NULL;
+ int r;
+
+ /* Let's synchronously lock all home directories managed by homed that have been marked for it. This
+ * way the key material required to access these volumes is hopefully removed from memory. */
+
+ r = sd_bus_open_system(&bus);
+ if (r < 0)
+ return log_error_errno(r, "Failed to connect to system bus: %m");
+
+ r = bus_message_new_method_call(bus, &m, bus_home_mgr, "LockAllHomes");
+ if (r < 0)
+ return bus_log_create_error(r);
+
+ /* If homed is not running it can't have any home directories active either. */
+ r = sd_bus_message_set_auto_start(m, false);
+ if (r < 0)
+ return log_error_errno(r, "Failed to disable auto-start of LockAllHomes() message: %m");
+
+ r = sd_bus_call(bus, m, DEFAULT_TIMEOUT_USEC, &error, NULL);
+ if (r < 0) {
+ if (!bus_error_is_unknown_service(&error))
+ return log_error_errno(r, "Failed to lock home directories: %s", bus_error_message(&error, r));
+
+ log_debug("systemd-homed is not running, locking of home directories skipped.");
+ } else
+ log_debug("Successfully requested locking of all home directories.");
+ return 0;
+}
+
+static int execute(
+ const SleepConfig *sleep_config,
+ SleepOperation operation,
+ const char *action) {
+
+ const char *arguments[] = {
+ NULL,
+ "pre",
+ /* NB: we use 'arg_operation' instead of 'operation' here, as we want to communicate the overall
+ * operation here, not the specific one, in case of s2h. */
+ sleep_operation_to_string(arg_operation),
+ NULL
+ };
+ static const char* const dirs[] = {
+ SYSTEM_SLEEP_PATH,
+ NULL
+ };
+
+ _cleanup_(hibernation_device_done) HibernationDevice hibernation_device = {};
+ _cleanup_close_ int state_fd = -EBADF;
+ int r;
+
+ assert(sleep_config);
+ assert(operation >= 0);
+ assert(operation < _SLEEP_OPERATION_CONFIG_MAX); /* Others are handled by execute_s2h() instead */
+
+ if (strv_isempty(sleep_config->states[operation]))
+ return log_error_errno(SYNTHETIC_ERRNO(EINVAL),
+ "No sleep states configured for sleep operation %s, can't sleep.",
+ sleep_operation_to_string(operation));
+
+ /* This file is opened first, so that if we hit an error, we can abort before modifying any state. */
+ state_fd = open("/sys/power/state", O_WRONLY|O_CLOEXEC);
+ if (state_fd < 0)
+ return -errno;
+
+ /* Configure hibernation settings if we are supposed to hibernate */
+ if (sleep_operation_is_hibernation(operation)) {
+ bool resume_set;
+
+ r = find_suitable_hibernation_device(&hibernation_device);
+ if (r < 0)
+ return log_error_errno(r, "Failed to find location to hibernate to: %m");
+ resume_set = r > 0;
+
+ r = write_efi_hibernate_location(&hibernation_device, !resume_set);
+ if (!resume_set) {
+ if (r == -EOPNOTSUPP)
+ return log_error_errno(r, "No valid 'resume=' option found, refusing to hibernate.");
+ if (r < 0)
+ return r;
+
+ r = write_resume_config(hibernation_device.devno, hibernation_device.offset, hibernation_device.path);
+ if (r < 0)
+ goto fail;
+ }
+
+ r = write_mode(sleep_config->modes[operation]);
+ if (r < 0) {
+ log_error_errno(r, "Failed to write mode to /sys/power/disk: %m");
+ goto fail;
+ }
+ }
+
+ /* Pass an action string to the call-outs. This is mostly our operation string, except if the
+ * hibernate step of s-t-h fails, in which case we communicate that with a separate action. */
+ if (!action)
+ action = sleep_operation_to_string(operation);
+
+ if (setenv("SYSTEMD_SLEEP_ACTION", action, /* overwrite = */ 1) < 0)
+ log_warning_errno(errno, "Failed to set SYSTEMD_SLEEP_ACTION=%s, ignoring: %m", action);
+
+ (void) execute_directories(dirs, DEFAULT_TIMEOUT_USEC, NULL, NULL, (char **) arguments, NULL, EXEC_DIR_PARALLEL | EXEC_DIR_IGNORE_ERRORS);
+ (void) lock_all_homes();
+
+ log_struct(LOG_INFO,
+ "MESSAGE_ID=" SD_MESSAGE_SLEEP_START_STR,
+ LOG_MESSAGE("Performing sleep operation '%s'...", sleep_operation_to_string(operation)),
+ "SLEEP=%s", sleep_operation_to_string(arg_operation));
+
+ r = write_state(state_fd, sleep_config->states[operation]);
+ if (r < 0)
+ log_struct_errno(LOG_ERR, r,
+ "MESSAGE_ID=" SD_MESSAGE_SLEEP_STOP_STR,
+ LOG_MESSAGE("Failed to put system to sleep. System resumed again: %m"),
+ "SLEEP=%s", sleep_operation_to_string(arg_operation));
+ else
+ log_struct(LOG_INFO,
+ "MESSAGE_ID=" SD_MESSAGE_SLEEP_STOP_STR,
+ LOG_MESSAGE("System returned from sleep operation '%s'.", sleep_operation_to_string(arg_operation)),
+ "SLEEP=%s", sleep_operation_to_string(arg_operation));
+
+ arguments[1] = "post";
+ (void) execute_directories(dirs, DEFAULT_TIMEOUT_USEC, NULL, NULL, (char **) arguments, NULL, EXEC_DIR_PARALLEL | EXEC_DIR_IGNORE_ERRORS);
+
+ if (r >= 0)
+ return 0;
+
+fail:
+ if (sleep_operation_is_hibernation(operation) && is_efi_boot())
+ (void) efi_set_variable(EFI_SYSTEMD_VARIABLE(HibernateLocation), NULL, 0);
+
+ return r;
+}
+
+/* Return true if wakeup type is APM timer */
+static int check_wakeup_type(void) {
+ static const char dmi_object_path[] = "/sys/firmware/dmi/entries/1-0/raw";
+ uint8_t wakeup_type_byte, tablesize;
+ _cleanup_free_ char *buf = NULL;
+ size_t bufsize;
+ int r;
+
+ /* implementation via dmi/entries */
+ r = read_full_virtual_file(dmi_object_path, &buf, &bufsize);
+ if (r < 0)
+ return log_debug_errno(r, "Unable to read %s: %m", dmi_object_path);
+ if (bufsize < 25)
+ return log_debug_errno(SYNTHETIC_ERRNO(EINVAL),
+ "Only read %zu bytes from %s (expected 25)",
+ bufsize, dmi_object_path);
+
+ /* index 1 stores the size of table */
+ tablesize = (uint8_t) buf[1];
+ if (tablesize < 25)
+ return log_debug_errno(SYNTHETIC_ERRNO(EINVAL),
+ "Table size less than the index[0x18] where waketype byte is available.");
+
+ wakeup_type_byte = (uint8_t) buf[24];
+ /* 0 is Reserved and 8 is AC Power Restored. As per table 12 in
+ * https://www.dmtf.org/sites/default/files/standards/documents/DSP0134_3.4.0.pdf */
+ if (wakeup_type_byte >= 128)
+ return log_debug_errno(SYNTHETIC_ERRNO(EINVAL), "Expected value in range 0-127");
+
+ if (wakeup_type_byte == 3) {
+ log_debug("DMI BIOS System Information indicates wakeup type is APM Timer");
+ return true;
+ }
+
+ return false;
+}
+
+static int custom_timer_suspend(const SleepConfig *sleep_config) {
+ usec_t hibernate_timestamp;
+ int r;
+
+ assert(sleep_config);
+
+ hibernate_timestamp = usec_add(now(CLOCK_BOOTTIME), sleep_config->hibernate_delay_usec);
+
+ while (battery_is_discharging_and_low() == 0) {
+ _cleanup_hashmap_free_ Hashmap *last_capacity = NULL, *current_capacity = NULL;
+ _cleanup_close_ int tfd = -EBADF;
+ struct itimerspec ts = {};
+ usec_t suspend_interval;
+ bool woken_by_timer;
+
+ tfd = timerfd_create(CLOCK_BOOTTIME_ALARM, TFD_NONBLOCK|TFD_CLOEXEC);
+ if (tfd < 0)
+ return log_error_errno(errno, "Error creating timerfd: %m");
+
+ /* Store current battery capacity before suspension */
+ r = fetch_batteries_capacity_by_name(&last_capacity);
+ if (r < 0)
+ return log_error_errno(r, "Error fetching battery capacity percentage: %m");
+
+ if (hashmap_isempty(last_capacity))
+ /* In case of no battery, system suspend interval will be set to HibernateDelaySec= or 2 hours. */
+ suspend_interval = timestamp_is_set(hibernate_timestamp)
+ ? sleep_config->hibernate_delay_usec : DEFAULT_HIBERNATE_DELAY_USEC_NO_BATTERY;
+ else {
+ r = get_total_suspend_interval(last_capacity, &suspend_interval);
+ if (r < 0) {
+ log_debug_errno(r, "Failed to estimate suspend interval using previous discharge rate, ignoring: %m");
+ /* In case of any errors, especially when we do not know the battery
+ * discharging rate, system suspend interval will be set to
+ * SuspendEstimationSec=. */
+ suspend_interval = sleep_config->suspend_estimation_usec;
+ }
+ }
+
+ /* Do not suspend more than HibernateDelaySec= */
+ usec_t before_timestamp = now(CLOCK_BOOTTIME);
+ suspend_interval = MIN(suspend_interval, usec_sub_unsigned(hibernate_timestamp, before_timestamp));
+ if (suspend_interval <= 0)
+ break; /* system should hibernate */
+
+ log_debug("Set timerfd wake alarm for %s", FORMAT_TIMESPAN(suspend_interval, USEC_PER_SEC));
+ /* Wake alarm for system with or without battery to hibernate or estimate discharge rate whichever is applicable */
+ timespec_store(&ts.it_value, suspend_interval);
+
+ if (timerfd_settime(tfd, 0, &ts, NULL) < 0)
+ return log_error_errno(errno, "Error setting battery estimate timer: %m");
+
+ r = execute(sleep_config, SLEEP_SUSPEND, NULL);
+ if (r < 0)
+ return r;
+
+ r = fd_wait_for_event(tfd, POLLIN, 0);
+ if (r < 0)
+ return log_error_errno(r, "Error polling timerfd: %m");
+ /* Store fd_wait status */
+ woken_by_timer = FLAGS_SET(r, POLLIN);
+
+ r = fetch_batteries_capacity_by_name(&current_capacity);
+ if (r < 0 || hashmap_isempty(current_capacity)) {
+ /* In case of no battery or error while getting charge level, no need to measure
+ * discharge rate. Instead the system should wake up if it is manual wakeup or
+ * hibernate if this is a timer wakeup. */
+ if (r < 0)
+ log_debug_errno(r, "Battery capacity percentage unavailable, cannot estimate discharge rate: %m");
+ else
+ log_debug("No battery found.");
+ if (!woken_by_timer)
+ return 0;
+ break;
+ }
+
+ usec_t after_timestamp = now(CLOCK_BOOTTIME);
+ log_debug("Attempting to estimate battery discharge rate after wakeup from %s sleep",
+ FORMAT_TIMESPAN(after_timestamp - before_timestamp, USEC_PER_HOUR));
+
+ if (after_timestamp != before_timestamp) {
+ r = estimate_battery_discharge_rate_per_hour(last_capacity, current_capacity, before_timestamp, after_timestamp);
+ if (r < 0)
+ log_warning_errno(r, "Failed to estimate and update battery discharge rate, ignoring: %m");
+ } else
+ log_debug("System woke up too early to estimate discharge rate");
+
+ if (!woken_by_timer)
+ /* Return as manual wakeup done. This also will return in case battery was charged during suspension */
+ return 0;
+
+ r = check_wakeup_type();
+ if (r < 0)
+ log_debug_errno(r, "Failed to check hardware wakeup type, ignoring: %m");
+ if (r > 0) {
+ log_debug("wakeup type is APM timer");
+ /* system should hibernate */
+ break;
+ }
+ }
+
+ return 1;
+}
+
+/* Freeze when invoked and thaw on cleanup */
+static int freeze_thaw_user_slice(const char **method) {
+ _cleanup_(sd_bus_error_free) sd_bus_error error = SD_BUS_ERROR_NULL;
+ _cleanup_(sd_bus_flush_close_unrefp) sd_bus *bus = NULL;
+ int r;
+
+ if (!method || !*method)
+ return 0;
+
+ r = bus_connect_system_systemd(&bus);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to open connection to systemd: %m");
+
+ (void) sd_bus_set_method_call_timeout(bus, FREEZE_TIMEOUT);
+
+ r = bus_call_method(bus, bus_systemd_mgr, *method, &error, NULL, "s", SPECIAL_USER_SLICE);
+ if (r < 0)
+ return log_debug_errno(r, "Failed to execute operation: %s", bus_error_message(&error, r));
+
+ return 1;
+}
+
+static int execute_s2h(const SleepConfig *sleep_config) {
+ _unused_ _cleanup_(freeze_thaw_user_slice) const char *auto_method_thaw = "ThawUnit";
+ int r;
+
+ assert(sleep_config);
+
+ r = freeze_thaw_user_slice(&(const char*) { "FreezeUnit" });
+ if (r < 0)
+ log_debug_errno(r, "Failed to freeze unit user.slice, ignoring: %m");
+
+ /* Only check if we have automated battery alarms if HibernateDelaySec= is not set, as in that case
+ * we'll busy poll for the configured interval instead */
+ if (!timestamp_is_set(sleep_config->hibernate_delay_usec)) {
+ r = check_wakeup_type();
+ if (r < 0)
+ log_debug_errno(r, "Failed to check hardware wakeup type, ignoring: %m");
+ else {
+ r = battery_trip_point_alarm_exists();
+ if (r < 0)
+ log_debug_errno(r, "Failed to check whether acpi_btp support is enabled or not, ignoring: %m");
+ }
+ } else
+ r = 0; /* Force fallback path */
+
+ if (r > 0) { /* If we have both wakeup alarms and battery trip point support, use them */
+ log_debug("Attempting to suspend...");
+ r = execute(sleep_config, SLEEP_SUSPEND, NULL);
+ if (r < 0)
+ return r;
+
+ r = check_wakeup_type();
+ if (r < 0)
+ return log_debug_errno(r, "Failed to check hardware wakeup type: %m");
+
+ if (r == 0)
+ /* For APM Timer wakeup, system should hibernate else wakeup */
+ return 0;
+ } else {
+ r = custom_timer_suspend(sleep_config);
+ if (r < 0)
+ return log_debug_errno(r, "Suspend cycle with manual battery discharge rate estimation failed: %m");
+ if (r == 0)
+ /* manual wakeup */
+ return 0;
+ }
+ /* For above custom timer, if 1 is returned, system will directly hibernate */
+
+ log_debug("Attempting to hibernate");
+ r = execute(sleep_config, SLEEP_HIBERNATE, NULL);
+ if (r < 0) {
+ log_notice("Couldn't hibernate, will try to suspend again.");
+
+ r = execute(sleep_config, SLEEP_SUSPEND, "suspend-after-failed-hibernate");
+ if (r < 0)
+ return r;
+ }
+
+ return 0;
+}
+
+static int help(void) {
+ _cleanup_free_ char *link = NULL;
+ int r;
+
+ r = terminal_urlify_man("systemd-suspend.service", "8", &link);
+ if (r < 0)
+ return log_oom();
+
+ printf("%s COMMAND\n\n"
+ "Suspend the system, hibernate the system, or both.\n\n"
+ " -h --help Show this help and exit\n"
+ " --version Print version string and exit\n"
+ "\nCommands:\n"
+ " suspend Suspend the system\n"
+ " hibernate Hibernate the system\n"
+ " hybrid-sleep Both hibernate and suspend the system\n"
+ " suspend-then-hibernate Initially suspend and then hibernate\n"
+ " the system after a fixed period of time or\n"
+ " when battery is low\n"
+ "\nSee the %s for details.\n",
+ program_invocation_short_name,
+ link);
+
+ return 0;
+}
+
+static int parse_argv(int argc, char *argv[]) {
+
+ enum {
+ ARG_VERSION = 0x100,
+ };
+
+ static const struct option options[] = {
+ { "help", no_argument, NULL, 'h' },
+ { "version", no_argument, NULL, ARG_VERSION },
+ {}
+ };
+
+ int c;
+
+ assert(argc >= 0);
+ assert(argv);
+
+ while ((c = getopt_long(argc, argv, "h", options, NULL)) >= 0)
+ switch (c) {
+
+ case 'h':
+ return help();
+
+ case ARG_VERSION:
+ return version();
+
+ case '?':
+ return -EINVAL;
+
+ default:
+ assert_not_reached();
+
+ }
+
+ if (argc - optind != 1)
+ return log_error_errno(SYNTHETIC_ERRNO(EINVAL),
+ "Usage: %s COMMAND",
+ program_invocation_short_name);
+
+ arg_operation = sleep_operation_from_string(argv[optind]);
+ if (arg_operation < 0)
+ return log_error_errno(SYNTHETIC_ERRNO(EINVAL), "Unknown command '%s'.", argv[optind]);
+
+ return 1 /* work to do */;
+}
+
+static int run(int argc, char *argv[]) {
+ _cleanup_(sleep_config_freep) SleepConfig *sleep_config = NULL;
+ int r;
+
+ log_setup();
+
+ r = parse_argv(argc, argv);
+ if (r <= 0)
+ return r;
+
+ r = parse_sleep_config(&sleep_config);
+ if (r < 0)
+ return r;
+
+ if (!sleep_config->allow[arg_operation])
+ return log_error_errno(SYNTHETIC_ERRNO(EACCES),
+ "Sleep operation \"%s\" is disabled by configuration, refusing.",
+ sleep_operation_to_string(arg_operation));
+
+ switch (arg_operation) {
+
+ case SLEEP_SUSPEND_THEN_HIBERNATE:
+ r = execute_s2h(sleep_config);
+ break;
+
+ case SLEEP_HYBRID_SLEEP:
+ r = execute(sleep_config, SLEEP_HYBRID_SLEEP, NULL);
+ if (r < 0) {
+ /* If we can't hybrid sleep, then let's try to suspend at least. After all, the user
+ * asked us to do both: suspend + hibernate, and it's almost certainly the
+ * hibernation that failed, hence still do the other thing, the suspend. */
+
+ log_notice_errno(r, "Couldn't hybrid sleep, will try to suspend instead: %m");
+
+ r = execute(sleep_config, SLEEP_SUSPEND, "suspend-after-failed-hybrid-sleep");
+ }
+
+ break;
+
+ default:
+ r = execute(sleep_config, arg_operation, NULL);
+ break;
+
+ }
+
+ return r;
+}
+
+DEFINE_MAIN_FUNCTION(run);
diff --git a/src/sleep/sleep.conf b/src/sleep/sleep.conf
new file mode 100644
index 0000000..fad95b3
--- /dev/null
+++ b/src/sleep/sleep.conf
@@ -0,0 +1,27 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it under the
+# terms of the GNU Lesser General Public License as published by the Free
+# Software Foundation; either version 2.1 of the License, or (at your option)
+# any later version.
+#
+# Entries in this file show the compile time defaults. Local configuration
+# should be created by either modifying this file (or a copy of it placed in
+# /etc/ if the original file is shipped in /usr/), or by creating "drop-ins" in
+# the /etc/systemd/sleep.conf.d/ directory. The latter is generally
+# recommended. Defaults can be restored by simply deleting the main
+# configuration file and all drop-ins located in /etc/.
+#
+# Use 'systemd-analyze cat-config systemd/sleep.conf' to display the full config.
+#
+# See systemd-sleep.conf(5) for details.
+
+[Sleep]
+#AllowSuspend=yes
+#AllowHibernation=yes
+#AllowSuspendThenHibernate=yes
+#AllowHybridSleep=yes
+#SuspendState=mem standby freeze
+#HibernateMode=platform shutdown
+#HibernateDelaySec=
+#SuspendEstimationSec=60min
diff --git a/src/sleep/test-battery-capacity.c b/src/sleep/test-battery-capacity.c
new file mode 100644
index 0000000..1b3422a
--- /dev/null
+++ b/src/sleep/test-battery-capacity.c
@@ -0,0 +1,45 @@
+/* SPDX-License-Identifier: LGPL-2.1-or-later */
+
+#include <unistd.h>
+
+#include "battery-capacity.h"
+#include "errno-util.h"
+#include "hashmap.h"
+#include "log.h"
+#include "tests.h"
+
+TEST(fetch_batteries_capacity_by_name) {
+ _cleanup_hashmap_free_ Hashmap *capacity = NULL;
+ int r;
+
+ assert_se(fetch_batteries_capacity_by_name(&capacity) >= 0);
+ log_debug("fetch_batteries_capacity_by_name: %u entries", hashmap_size(capacity));
+
+ const char *name;
+ void *cap;
+ HASHMAP_FOREACH_KEY(cap, name, capacity) {
+ assert(cap); /* Anything non-null is fine. */
+ log_info("Battery %s: capacity = %i", name, get_capacity_by_name(capacity, name));
+ }
+
+ for (int i = 0; i < 2; i++) {
+ usec_t interval;
+
+ if (i > 0)
+ sleep(1);
+
+ r = get_total_suspend_interval(capacity, &interval);
+ assert_se(r >= 0 || r == -ENOENT);
+ log_info("%d: get_total_suspend_interval: %s", i,
+ r < 0 ? STRERROR(r) : FORMAT_TIMESPAN(interval, USEC_PER_SEC));
+ }
+}
+
+static int intro(void) {
+ if (getuid() != 0)
+ log_warning("This program is unlikely to work for unprivileged users");
+
+ return EXIT_SUCCESS;
+}
+
+DEFINE_TEST_MAIN_WITH_INTRO(LOG_DEBUG, intro);