summaryrefslogtreecommitdiffstats
path: root/src/tmpfiles/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/tmpfiles/meson.build')
-rw-r--r--src/tmpfiles/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/tmpfiles/meson.build b/src/tmpfiles/meson.build
new file mode 100644
index 0000000..8a24a21
--- /dev/null
+++ b/src/tmpfiles/meson.build
@@ -0,0 +1,38 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+systemd_tmpfiles_sources = files(
+ 'tmpfiles.c',
+ 'offline-passwd.c',
+)
+
+executables += [
+ executable_template + {
+ 'name' : 'systemd-tmpfiles',
+ 'public' : true,
+ 'conditions' : ['ENABLE_TMPFILES'],
+ 'sources' : systemd_tmpfiles_sources,
+ 'dependencies' : libacl,
+ },
+ executable_template + {
+ 'name' : 'systemd-tmpfiles.standalone',
+ 'public' : have_standalone_binaries,
+ 'conditions' : ['ENABLE_TMPFILES'],
+ 'sources' : systemd_tmpfiles_sources,
+ 'c_args' : '-DSTANDALONE',
+ 'link_with' : [
+ libbasic,
+ libbasic_gcrypt,
+ libshared_static,
+ libsystemd_static,
+ ],
+ 'dependencies' : libacl,
+ 'build_by_default' : have_standalone_binaries,
+ 'install' : have_standalone_binaries,
+ },
+ test_template + {
+ 'sources' : files(
+ 'test-offline-passwd.c',
+ 'offline-passwd.c',
+ ),
+ },
+]