summaryrefslogtreecommitdiffstats
path: root/test/TEST-23-UNIT-FILE
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-23-UNIT-FILE')
l---------test/TEST-23-UNIT-FILE/Makefile1
-rwxr-xr-xtest/TEST-23-UNIT-FILE/test.sh10
2 files changed, 11 insertions, 0 deletions
diff --git a/test/TEST-23-UNIT-FILE/Makefile b/test/TEST-23-UNIT-FILE/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-23-UNIT-FILE/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-23-UNIT-FILE/test.sh b/test/TEST-23-UNIT-FILE/test.sh
new file mode 100755
index 0000000..335f2fd
--- /dev/null
+++ b/test/TEST-23-UNIT-FILE/test.sh
@@ -0,0 +1,10 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="Tests for various unit file settings"
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+do_test "$@"