summaryrefslogtreecommitdiffstats
path: root/test/TEST-35-LOGIN
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-35-LOGIN')
l---------test/TEST-35-LOGIN/Makefile1
-rwxr-xr-xtest/TEST-35-LOGIN/test.sh16
2 files changed, 17 insertions, 0 deletions
diff --git a/test/TEST-35-LOGIN/Makefile b/test/TEST-35-LOGIN/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-35-LOGIN/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-35-LOGIN/test.sh b/test/TEST-35-LOGIN/test.sh
new file mode 100755
index 0000000..a781be7
--- /dev/null
+++ b/test/TEST-35-LOGIN/test.sh
@@ -0,0 +1,16 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="Tests for systemd-logind"
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+test_append_files() {
+ image_install -o evemu-device evemu-event
+ instmods uinput
+ generate_module_dependencies
+}
+
+do_test "$@"