summaryrefslogtreecommitdiffstats
path: root/test/TEST-68-PROPAGATE-EXIT-STATUS
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-68-PROPAGATE-EXIT-STATUS')
l---------test/TEST-68-PROPAGATE-EXIT-STATUS/Makefile1
-rwxr-xr-xtest/TEST-68-PROPAGATE-EXIT-STATUS/test.sh11
2 files changed, 12 insertions, 0 deletions
diff --git a/test/TEST-68-PROPAGATE-EXIT-STATUS/Makefile b/test/TEST-68-PROPAGATE-EXIT-STATUS/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-68-PROPAGATE-EXIT-STATUS/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-68-PROPAGATE-EXIT-STATUS/test.sh b/test/TEST-68-PROPAGATE-EXIT-STATUS/test.sh
new file mode 100755
index 0000000..eecd569
--- /dev/null
+++ b/test/TEST-68-PROPAGATE-EXIT-STATUS/test.sh
@@ -0,0 +1,11 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="Test propagation of exit status to On{Failure,Success}= dependencies"
+TEST_NO_QEMU=1
+
+# shellcheck source=test/test-functions
+. "$TEST_BASE_DIR/test-functions"
+
+do_test "$@"