summaryrefslogtreecommitdiffstats
path: root/test/TEST-84-STORAGETM
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-84-STORAGETM')
l---------test/TEST-84-STORAGETM/Makefile1
-rwxr-xr-xtest/TEST-84-STORAGETM/test.sh25
2 files changed, 26 insertions, 0 deletions
diff --git a/test/TEST-84-STORAGETM/Makefile b/test/TEST-84-STORAGETM/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-84-STORAGETM/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-84-STORAGETM/test.sh b/test/TEST-84-STORAGETM/test.sh
new file mode 100755
index 0000000..8a9730c
--- /dev/null
+++ b/test/TEST-84-STORAGETM/test.sh
@@ -0,0 +1,25 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="test storagetm"
+
+TEST_NO_NSPAWN=1
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+test_require_bin nvme
+
+modprobe -nv nvmet-tcp || exit 0
+
+test_append_files() {
+ inst_binary nvme
+
+ instmods "=nvme"
+ instmods configfs
+
+ generate_module_dependencies
+}
+
+do_test "$@"