summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:13:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:13:05 +0000
commitd89fede3849004be87494c62f2e5b8140c7d69c5 (patch)
tree5e000e46fe2807586a9ae25d96e7ab043323d91e /debian/rules
parentAdding upstream version 4.99.4. (diff)
downloadtcpdump-d89fede3849004be87494c62f2e5b8140c7d69c5.tar.xz
tcpdump-d89fede3849004be87494c62f2e5b8140c7d69c5.zip
Adding debian version 4.99.4-3.debian/4.99.4-3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6b41603
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -D_FILE_OFFSET_BITS=64
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- --with-crypto=yes --with-user=tcpdump
+
+override_dh_installdeb:
+ dh_apparmor --profile-name=usr.bin.tcpdump -ptcpdump
+ dh_installdeb