summaryrefslogtreecommitdiffstats
path: root/debian/patches/install.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/install.diff')
-rw-r--r--debian/patches/install.diff26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/install.diff b/debian/patches/install.diff
new file mode 100644
index 0000000..69a550f
--- /dev/null
+++ b/debian/patches/install.diff
@@ -0,0 +1,26 @@
+Description: Change man page install paths for Debian and don't install a versioned binary.
+Forwarded: not-needed
+Author: Romain Francoise <rfrancoise@debian.org>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -424,15 +424,14 @@
+ [ -d $(DESTDIR)$(bindir) ] || \
+ (mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
+ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(PROG).`cat ${srcdir}/VERSION`
+- [ -d $(DESTDIR)$(mandir)/man1 ] || \
+- (mkdir -p $(DESTDIR)$(mandir)/man1; chmod 755 $(DESTDIR)$(mandir)/man1)
+- $(INSTALL_DATA) $(PROG).1 $(DESTDIR)$(mandir)/man1/$(PROG).1
++ [ -d $(DESTDIR)$(mandir)/man8 ] || \
++ (mkdir -p $(DESTDIR)$(mandir)/man8; chmod 755 $(DESTDIR)$(mandir)/man8)
++ $(INSTALL_DATA) $(PROG).1 $(DESTDIR)$(mandir)/man8/$(PROG).8
+
+ uninstall:
+ rm -f $(DESTDIR)$(bindir)/$(PROG)
+ rm -f $(DESTDIR)$(bindir)/$(PROG).`cat ${srcdir}/VERSION`
+- rm -f $(DESTDIR)$(mandir)/man1/$(PROG).1
++ rm -f $(DESTDIR)$(mandir)/man8/$(PROG).8
+
+ lint:
+ lint -hbxn $(SRC) $(LIBNETDISSECT_SRC) | \