summaryrefslogtreecommitdiffstats
path: root/media/libtheora/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /media/libtheora/Makefile.in
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'media/libtheora/Makefile.in')
-rw-r--r--media/libtheora/Makefile.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/media/libtheora/Makefile.in b/media/libtheora/Makefile.in
new file mode 100644
index 0000000000..006310491d
--- /dev/null
+++ b/media/libtheora/Makefile.in
@@ -0,0 +1,24 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+
+ifdef GNU_AS
+ifeq ($(CPU_ARCH),arm)
+
+armfrag-gnu.s: armopts-gnu.S
+armidct-gnu.s: armopts-gnu.S
+armloop-gnu.s: armopts-gnu.S
+
+# armopts needs a specific rule, because arm2gnu.pl will always add the .S
+# suffix when translating the files that include it.
+armopts-gnu.S: $(srcdir)/lib/arm/armopts.s
+ $(PERL) $(srcdir)/lib/arm/arm2gnu.pl < $< > $@
+# For all others, we can use an implicit rule
+%-gnu.s: $(srcdir)/lib/arm/%.s
+ $(PERL) $(srcdir)/lib/arm/arm2gnu.pl < $< > $@
+
+endif
+endif
+
+include $(topsrcdir)/config/rules.mk