summaryrefslogtreecommitdiffstats
path: root/comm/tools/lint/ruff.yml
diff options
context:
space:
mode:
Diffstat (limited to 'comm/tools/lint/ruff.yml')
-rw-r--r--comm/tools/lint/ruff.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/comm/tools/lint/ruff.yml b/comm/tools/lint/ruff.yml
new file mode 100644
index 0000000000..1b7eb8a56b
--- /dev/null
+++ b/comm/tools/lint/ruff.yml
@@ -0,0 +1,17 @@
+---
+ruff:
+ description: An extremely fast Python linter, written in Rust
+ include: ["."]
+ extensions: ["py"]
+ support-files:
+ - "comm/**/.ruff.toml"
+ - "comm/**/ruff.toml"
+ - "comm/**/pyproject.toml"
+ - "tools/lint/python/ruff.py"
+ # Rules that should result in warnings rather than errors.
+ warning-rules: [PLR, PLW]
+ commroot: true
+ type: external
+ payload: commlint:lint_wrapper
+ wraps: python.ruff:lint
+ setup: python.ruff:setup