summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glean/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glean/Cargo.toml')
-rw-r--r--third_party/rust/glean/Cargo.toml102
1 files changed, 102 insertions, 0 deletions
diff --git a/third_party/rust/glean/Cargo.toml b/third_party/rust/glean/Cargo.toml
new file mode 100644
index 0000000000..3b8825f17f
--- /dev/null
+++ b/third_party/rust/glean/Cargo.toml
@@ -0,0 +1,102 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.62"
+name = "glean"
+version = "52.7.0"
+authors = [
+ "Jan-Erik Rediger <jrediger@mozilla.com>",
+ "The Glean Team <glean-team@mozilla.com>",
+]
+include = [
+ "/README.md",
+ "/LICENSE",
+ "/src",
+ "/tests",
+ "/Cargo.toml",
+]
+description = "Glean SDK Rust language bindings"
+readme = "README.md"
+keywords = [
+ "telemetry",
+ "glean",
+]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/glean"
+resolver = "1"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["serde"]
+
+[dependencies.crossbeam-channel]
+version = "0.5"
+
+[dependencies.glean-core]
+version = "52.7.0"
+
+[dependencies.inherent]
+version = "1"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.once_cell]
+version = "1.2.0"
+
+[dependencies.serde]
+version = "1.0.104"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.44"
+
+[dependencies.thiserror]
+version = "1.0.4"
+
+[dependencies.time]
+version = "0.1.40"
+
+[dependencies.uuid]
+version = "1.0"
+features = ["v4"]
+
+[dependencies.whatsys]
+version = "0.3.0"
+
+[dev-dependencies.env_logger]
+version = "0.10.0"
+features = [
+ "auto-color",
+ "humantime",
+]
+default-features = false
+
+[dev-dependencies.flate2]
+version = "1.0.19"
+
+[dev-dependencies.jsonschema-valid]
+version = "0.5.0"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[features]
+preinit_million_queue = ["glean-core/preinit_million_queue"]
+
+[badges.circle-ci]
+branch = "main"
+repository = "mozilla/glean"
+
+[badges.maintenance]
+status = "actively-developed"