summaryrefslogtreecommitdiffstats
path: root/third_party/rust/replace_with/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/replace_with/Cargo.toml')
-rw-r--r--third_party/rust/replace_with/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/replace_with/Cargo.toml b/third_party/rust/replace_with/Cargo.toml
new file mode 100644
index 0000000000..2fbd957b37
--- /dev/null
+++ b/third_party/rust/replace_with/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "replace_with"
+version = "0.1.7"
+authors = ["Alec Mocatta <alec@mocatta.net>"]
+description = "Temporarily take ownership of a value at a mutable location, and replace it with a new value based on the old one.\n"
+homepage = "https://github.com/alecmocatta/replace_with"
+documentation = "https://docs.rs/replace_with"
+readme = "README.md"
+keywords = ["mutability"]
+categories = ["rust-patterns"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/alecmocatta/replace_with"
+
+[features]
+default = ["std"]
+nightly = []
+panic_abort = []
+std = []
+[badges.azure-devops]
+build = "11"
+pipeline = "tests"
+project = "alecmocatta/replace_with"
+
+[badges.maintenance]
+status = "actively-developed"