diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-09-19 04:06:47 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-09-19 04:06:47 +0000 |
commit | 2ce56611800ca7122de83554b23dfc3d9de9cbc8 (patch) | |
tree | 0be905f5bdc5842c5203b84a19a615112db50708 | |
parent | Adding upstream version 1:2.1.5. (diff) | |
download | traceroute-upstream.tar.xz traceroute-upstream.zip |
Adding upstream version 1:2.1.6.upstream/1%2.1.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r-- | ChangeLog | 10 | ||||
-rw-r--r-- | VERSION | 2 | ||||
-rw-r--r-- | traceroute.spec | 2 | ||||
-rw-r--r-- | traceroute/traceroute.c | 7 |
4 files changed, 13 insertions, 8 deletions
@@ -1,3 +1,13 @@ +2024-09-14 Dmitry Butskoy <Dmitry@Butskoy.name> - 2.1.6 + + * Let getaddrinfo(3) select the default IPv4 or IPv6 protocol version + when it is not explicitly specified on the command line + (Jan Macku, SF bug #16) + + No more mandatory default to IPv4, follow rfc3484 and + the similar ping(1) behaviour. Drop DEF_AF macro. + + 2023-12-18 Dmitry Butskoy <Dmitry@Butskoy.name> - 2.1.5 * Fix rfc5837 parsing (Francois Rigault) @@ -1 +1 @@ -#define VERSION 2.1.5 +#define VERSION 2.1.6 diff --git a/traceroute.spec b/traceroute.spec index 1c95120..74cec28 100644 --- a/traceroute.spec +++ b/traceroute.spec @@ -1,6 +1,6 @@ Summary: Traces the route taken by packets over an IPv4/IPv6 network Name: traceroute -Version: 2.1.5 +Version: 2.1.6 Release: 1%{?dist} Group: Applications/Internet License: GPLv2+ diff --git a/traceroute/traceroute.c b/traceroute/traceroute.c index 08b850a..654fa50 100644 --- a/traceroute/traceroute.c +++ b/traceroute/traceroute.c @@ -77,9 +77,6 @@ #define DEF_SEND_SECS 0 #define DEF_DATA_LEN 40 /* all but IP header... */ #define MAX_PACKET_LEN 65000 -#ifndef DEF_AF -#define DEF_AF AF_INET -#endif #define ttl2hops(X) (((X) <= 64 ? 65 : ((X) <= 128 ? 129 : 256)) - (X)) @@ -224,9 +221,7 @@ static int getaddr (const char *name, sockaddr_any *addr) { } for (ai = res; ai; ai = ai->ai_next) { - if (ai->ai_family == af) break; - /* when af not specified, choose DEF_AF if present */ - if (!af && ai->ai_family == DEF_AF) + if (!af || ai->ai_family == af) break; } if (!ai) ai = res; /* anything... */ |