summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:06:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:06:48 +0000
commitefe7895064c828ca05feb552484a8d6839d6da83 (patch)
tree6fe5878951dffa835d8e3bfa32d2cf5b07460242
parentReleasing progress-linux version 1:2.1.5-1~progress7.99u1. (diff)
downloadtraceroute-efe7895064c828ca05feb552484a8d6839d6da83.tar.xz
traceroute-efe7895064c828ca05feb552484a8d6839d6da83.zip
Merging upstream version 1:2.1.6.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--ChangeLog10
-rw-r--r--VERSION2
-rw-r--r--traceroute.spec2
-rw-r--r--traceroute/traceroute.c7
4 files changed, 13 insertions, 8 deletions
diff --git a/ChangeLog b/ChangeLog
index ffd2100..27c84be 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2024-09-14 Dmitry Butskoy <Dmitry@Butskoy.name> - 2.1.6
+
+ * Let getaddrinfo(3) select the default IPv4 or IPv6 protocol version
+ when it is not explicitly specified on the command line
+ (Jan Macku, SF bug #16)
+
+ No more mandatory default to IPv4, follow rfc3484 and
+ the similar ping(1) behaviour. Drop DEF_AF macro.
+
+
2023-12-18 Dmitry Butskoy <Dmitry@Butskoy.name> - 2.1.5
* Fix rfc5837 parsing (Francois Rigault)
diff --git a/VERSION b/VERSION
index 374780e..15dad52 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-#define VERSION 2.1.5
+#define VERSION 2.1.6
diff --git a/traceroute.spec b/traceroute.spec
index 1c95120..74cec28 100644
--- a/traceroute.spec
+++ b/traceroute.spec
@@ -1,6 +1,6 @@
Summary: Traces the route taken by packets over an IPv4/IPv6 network
Name: traceroute
-Version: 2.1.5
+Version: 2.1.6
Release: 1%{?dist}
Group: Applications/Internet
License: GPLv2+
diff --git a/traceroute/traceroute.c b/traceroute/traceroute.c
index 08b850a..654fa50 100644
--- a/traceroute/traceroute.c
+++ b/traceroute/traceroute.c
@@ -77,9 +77,6 @@
#define DEF_SEND_SECS 0
#define DEF_DATA_LEN 40 /* all but IP header... */
#define MAX_PACKET_LEN 65000
-#ifndef DEF_AF
-#define DEF_AF AF_INET
-#endif
#define ttl2hops(X) (((X) <= 64 ? 65 : ((X) <= 128 ? 129 : 256)) - (X))
@@ -224,9 +221,7 @@ static int getaddr (const char *name, sockaddr_any *addr) {
}
for (ai = res; ai; ai = ai->ai_next) {
- if (ai->ai_family == af) break;
- /* when af not specified, choose DEF_AF if present */
- if (!af && ai->ai_family == DEF_AF)
+ if (!af || ai->ai_family == af)
break;
}
if (!ai) ai = res; /* anything... */