summaryrefslogtreecommitdiffstats
path: root/debian/patches/01-add-a-manpage-for-lsusb.py.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01-add-a-manpage-for-lsusb.py.patch')
-rw-r--r--debian/patches/01-add-a-manpage-for-lsusb.py.patch110
1 files changed, 110 insertions, 0 deletions
diff --git a/debian/patches/01-add-a-manpage-for-lsusb.py.patch b/debian/patches/01-add-a-manpage-for-lsusb.py.patch
new file mode 100644
index 0000000..27adef8
--- /dev/null
+++ b/debian/patches/01-add-a-manpage-for-lsusb.py.patch
@@ -0,0 +1,110 @@
+commit 83690ec408b2619866dc18c9ab94d9f6bc2c734d
+Author: Aurelien Jarno <aurelien@aurel32.net>
+Date: Wed Jan 3 10:29:39 2024 +0100
+
+ Add a manpage for lsusb.py
+
+ Signed-off-by: Sam Morris <sam@robots.org.uk>
+ Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
+
+diff --git a/Makefile.am b/Makefile.am
+index ae9e383..d3a9025 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -47,11 +47,13 @@ usbreset_SOURCES = \
+
+ man_MANS = \
+ lsusb.8 \
++ lsusb.py.1 \
+ usbhid-dump.8 \
+ usb-devices.1
+
+ EXTRA_DIST = \
+ lsusb.8.in \
++ lsusb.py.1.in \
+ usbhid-dump.8.in \
+ usb-devices.1.in \
+ usb-devices \
+@@ -69,6 +71,9 @@ lsusb.py: $(srcdir)/lsusb.py.in
+ lsusb.8: $(srcdir)/lsusb.8.in
+ sed 's|VERSION|$(VERSION)|g' $< >$@
+
++lsusb.py.1: $(srcdir)/lsusb.py.1.in
++ sed 's|VERSION|$(VERSION)|g' $< >$@
++
+ usbhid-dump.8: $(srcdir)/usbhid-dump.8.in
+ sed 's|VERSION|$(VERSION)|g' $< >$@
+
+diff --git a/lsusb.py.1.in b/lsusb.py.1.in
+new file mode 100644
+index 0000000..41dcd1c
+--- /dev/null
++++ b/lsusb.py.1.in
+@@ -0,0 +1,67 @@
++.\"SPDX-License-Identifier: GPL-2.0-only
++.\"Copyright (c) 1999 Thomas Sailer <sailer@ife.ee.ethz.ch>
++.\"Copyright (c) 2020 Sam Morris <sam@robots.org.uk>
++.TH lsusb.py 1 "03 January 2024" "usbutils-VERSION" "Linux USB Utilities"
++.IX lsusb.py
++.SH NAME
++lsusb.py \- list USB devices
++.SH SYNOPSIS
++.B lsusb.py
++[
++.I options
++]
++.SH DESCRIPTION
++.B lsusb.py
++is a utility for displaying information about USB buses in the system and the
++devices connected to them. It uses the
++.B usb.ids
++file to associate a human-readable name to the vendor and product IDs.
++.PP
++In comparison with
++.BR lsusb (8),
++this program can display additional information such as the interface speed of
++a device, and details of a device's interfaces including the driver bound to
++them and Linux devices provided by the driver, and the details of device and
++interface endpoints.
++.SH OPTIONS
++.TP
++.BR \-h ", " \-\-help
++Displays options supported by
++.BR lsusb (1).
++.TP
++.BR \-i ", " \-\-interfaces
++Display information about the interfaces of each device, excluding hubs.
++.TP
++.BR \-I ", " \-\-hub\-interfaces
++Display information about the interfaces of each device, including hubs., excluding hubs.
++.TP
++.BR \-u ", " \-\-hide\-empty\-hubs
++Suppress information about hubs that have no devices connected.
++.TP
++.BR \-U ", " \-\-hide\-hubs
++Suppress information about hubs, even if they have devices connected.
++.TP
++.BR \-c ", " \-\-color
++Use color
++.TP
++.BR \-C ", " \-\-no\-color
++Don't use color
++.TP
++.BR \-e ", " \-\-endpoints
++Include information about device (and interface, with
++.BR -i )
++endpoints.
++.TP
++.BR \-f ", " \-\-usbids\-path
++Overrides the path of the
++.B usb.ids
++file.
++
++.SH SEE ALSO
++.BR lspci (8),
++.BR lsusb (8),
++.BR usbview (8).
++
++.SH AUTHOR
++Thomas Sailer, <sailer@ife.ee.ethz.ch>,
++Sam Morris <sam@robots.org.uk>.