summaryrefslogtreecommitdiffstats
path: root/usbhid-dump/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'usbhid-dump/Makefile.am')
-rw-r--r--usbhid-dump/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/usbhid-dump/Makefile.am b/usbhid-dump/Makefile.am
new file mode 100644
index 0000000..3ba22f0
--- /dev/null
+++ b/usbhid-dump/Makefile.am
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# Copyright (C) 2009-2010 Nikolai Kondrashov
+#
+# This file is part of usbhid-dump.
+
+SUBDIRS = src
+
+dist_noinst_SCRIPTS = bootstrap
+
+dist-hook:
+ @set -e; \
+ if test -d "$(srcdir)/.git"; then \
+ echo Generating ChangeLog; \
+ ( cd "$(srcdir)" && auxdir/missing --run git log ) > \
+ ChangeLog.tmp; \
+ mv -f ChangeLog.tmp "$(distdir)/ChangeLog"; \
+ else \
+ echo Skipping ChangeLog generation: no .git directory >&2; \
+ fi
+