summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:06:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:06:41 +0000
commit1cc124bf09ff57dfc2dc9f6e4d2f40a0efb9bbc0 (patch)
tree33f3528cd5ea0f41b235f56f2581ed6920df754c
parentReleasing progress-linux version 2.40-5~progress7.99u1. (diff)
downloadutil-linux-1cc124bf09ff57dfc2dc9f6e4d2f40a0efb9bbc0.tar.xz
util-linux-1cc124bf09ff57dfc2dc9f6e4d2f40a0efb9bbc0.zip
Merging debian version 2.40-6.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/upstream/Revert-lib-pager-Apply-pager-specific-fixes-only-when-nee.patch59
-rw-r--r--debian/patches/upstream/audit-arch.h-add-defines-for-m68k-sh.patch40
4 files changed, 108 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6c15771..5403187 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+util-linux (2.40-6) unstable; urgency=medium
+
+ * Add upstream patches fixing enosys on m68k, sh and dmesg -H output
+ (Closes: #1068831, #1068691)
+
+ -- Chris Hofstaedtler <zeha@debian.org> Mon, 15 Apr 2024 09:51:01 +0200
+
util-linux (2.40-5~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/series b/debian/patches/series
index 0bd4eb1..d7dddf5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -8,5 +8,7 @@ upstream/lsfd-add-LSFD_DEBUG-env-var-for-debugging.patch
upstream/tests-test_mkfds-sockdiag-verify-the-recived-message.patch
debian/tests-mark-fadvise-drop-as-known-failing-on-buildds.patch
upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch
+upstream/audit-arch.h-add-defines-for-m68k-sh.patch
+upstream/Revert-lib-pager-Apply-pager-specific-fixes-only-when-nee.patch
progress-linux/0001-agetty-prompt.patch
progress-linux/0002-login-prompt.patch
diff --git a/debian/patches/upstream/Revert-lib-pager-Apply-pager-specific-fixes-only-when-nee.patch b/debian/patches/upstream/Revert-lib-pager-Apply-pager-specific-fixes-only-when-nee.patch
new file mode 100644
index 0000000..6bd7244
--- /dev/null
+++ b/debian/patches/upstream/Revert-lib-pager-Apply-pager-specific-fixes-only-when-nee.patch
@@ -0,0 +1,59 @@
+From: =?utf-8?q?Thomas_Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Sat, 13 Apr 2024 09:42:39 +0200
+Subject: Revert "lib/pager: Apply pager-specific fixes only when needed"
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Less is not always detectable, as it can be hidden behind symlinks or
+wrapper as for example in a default Debian installation.
+Also testing for the literal string "less" does not match full path
+specifications like "/usr/bin/less".
+
+Instead always apply the fixes.
+
+This reverts commit c10ad975895372122f72c8d9da089b6ea69f778b.
+Closes #2951
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+Debian-Bug: 1068831
+---
+ lib/pager.c | 12 +++---------
+ 1 file changed, 3 insertions(+), 9 deletions(-)
+
+diff --git a/lib/pager.c b/lib/pager.c
+index 5f62a78..47f1233 100644
+--- a/lib/pager.c
++++ b/lib/pager.c
+@@ -85,9 +85,7 @@ static int start_command(struct child_process *cmd)
+ close(cmd->in);
+ }
+
+- if (cmd->preexec_cb)
+- cmd->preexec_cb();
+-
++ cmd->preexec_cb();
+ execvp(cmd->argv[0], (char *const*) cmd->argv);
+ errexec(cmd->argv[0]);
+ }
+@@ -142,7 +140,7 @@ static int finish_command(struct child_process *cmd)
+ return wait_or_whine(cmd->pid);
+ }
+
+-static void pager_preexec_less(void)
++static void pager_preexec(void)
+ {
+ /*
+ * Work around bug in "less" by not starting it until we
+@@ -242,11 +240,7 @@ static void __setup_pager(void)
+ pager_argv[2] = pager;
+ pager_process.argv = pager_argv;
+ pager_process.in = -1;
+-
+- if (!strncmp(pager, "less", 4))
+- pager_process.preexec_cb = pager_preexec_less;
+- else
+- pager_process.preexec_cb = NULL;
++ pager_process.preexec_cb = pager_preexec;
+
+ if (start_command(&pager_process))
+ return;
diff --git a/debian/patches/upstream/audit-arch.h-add-defines-for-m68k-sh.patch b/debian/patches/upstream/audit-arch.h-add-defines-for-m68k-sh.patch
new file mode 100644
index 0000000..1c74ff1
--- /dev/null
+++ b/debian/patches/upstream/audit-arch.h-add-defines-for-m68k-sh.patch
@@ -0,0 +1,40 @@
+From: Chris Hofstaedtler <zeha@debian.org>
+Date: Tue, 9 Apr 2024 10:30:32 +0200
+Subject: audit-arch.h: add defines for m68k, sh
+
+John Paul Adrian Glaubitz points out that libseccomp needs to release 2.6.0,
+too.
+
+Upstream commit 5ebf0edb0a0531cba801c7791543c610725bf944.
+
+Signed-off-by: Chris Hofstaedtler <zeha@debian.org>
+---
+ include/audit-arch.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/include/audit-arch.h b/include/audit-arch.h
+index ade1824..9afc663 100644
+--- a/include/audit-arch.h
++++ b/include/audit-arch.h
+@@ -35,6 +35,8 @@
+ # endif
+ #elif __powerpc__
+ # define SECCOMP_ARCH_NATIVE AUDIT_ARCH_PPC
++#elif __m68k__
++# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_M68K
+ #elif __mips__
+ # if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
+ # define SECCOMP_ARCH_NATIVE AUDIT_ARCH_MIPS
+@@ -47,6 +49,12 @@
+ # else
+ # define SECCOMP_ARCH_NATIVE AUDIT_ARCH_ARCV2
+ # endif
++#elif __sh__
++# if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
++# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_SH
++# else
++# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_SHEL
++# endif
+ #elif __sparc__
+ # if __SIZEOF_POINTER__ == 4
+ # define SECCOMP_ARCH_NATIVE AUDIT_ARCH_SPARC