summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 21:18:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 21:18:13 +0000
commit8a95bbcc792c9872b419e0c7e5b647e4169e121e (patch)
tree063401f53ffbca7fb20ebc0c08217547ec94ac27
parentReleasing progress-linux version 2.40-4~progress7.99u1. (diff)
downloadutil-linux-8a95bbcc792c9872b419e0c7e5b647e4169e121e.tar.xz
util-linux-8a95bbcc792c9872b419e0c7e5b647e4169e121e.zip
Merging debian version 2.40-5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch55
-rwxr-xr-xdebian/rules11
-rwxr-xr-xdebian/util-linux-extra.install1
-rwxr-xr-xdebian/util-linux-extra.manpages1
-rwxr-xr-xdebian/util-linux-locales.install1
7 files changed, 73 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index a108a17..34ab070 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+util-linux (2.40-5) unstable; urgency=medium
+
+ * Release to unstable.
+ * Apply upstream patch to skip lsfd test on kernels lacking features
+ * d/rules: print deleted files
+ * Install new enosys program (into util-linux-extra)
+
+ -- Chris Hofstaedtler <zeha@debian.org> Mon, 08 Apr 2024 16:14:54 +0200
+
util-linux (2.40-4~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/series b/debian/patches/series
index 9fa3f16..0bd4eb1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,5 +7,6 @@ debian/tests-mark-lsfd-tests-failing-in-sbuild.patch
upstream/lsfd-add-LSFD_DEBUG-env-var-for-debugging.patch
upstream/tests-test_mkfds-sockdiag-verify-the-recived-message.patch
debian/tests-mark-fadvise-drop-as-known-failing-on-buildds.patch
+upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch
progress-linux/0001-agetty-prompt.patch
progress-linux/0002-login-prompt.patch
diff --git a/debian/patches/upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch b/debian/patches/upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch
new file mode 100644
index 0000000..cdd72f6
--- /dev/null
+++ b/debian/patches/upstream/tests-lsfd-mkfds-multiplexing-skip-if-proc-pid-syscall-is.patch
@@ -0,0 +1,55 @@
+From: Masatake YAMATO <yamato@redhat.com>
+Date: Fri, 5 Apr 2024 04:00:45 +0900
+Subject: tests: (lsfd::mkfds-multiplexing) skip if /proc/$pid/syscall is
+ broken
+
+Close #2867
+Close #2887
+
+We should skip the test case on the platforms where /proc/$pid/syscall
+doesn't report correct system call number. On such platforms,
+
+Signed-off-by: Masatake YAMATO <yamato@redhat.com>
+---
+ tests/ts/lsfd/mkfds-multiplexing | 16 +++++++++++++++-
+ 1 file changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/tests/ts/lsfd/mkfds-multiplexing b/tests/ts/lsfd/mkfds-multiplexing
+index 8cc7f31..a53f6eb 100755
+--- a/tests/ts/lsfd/mkfds-multiplexing
++++ b/tests/ts/lsfd/mkfds-multiplexing
+@@ -26,6 +26,8 @@ ts_check_test_command "$TS_HELPER_MKFDS"
+ # /proc/${PID}/syscall is rendered in the host side byteorder.
+ ts_skip_qemu_user
+
++ts_check_prog "cat"
++ts_check_prog "cut"
+ ts_check_prog "grep"
+
+ ts_cd "$TS_OUTDIR"
+@@ -44,12 +46,24 @@ for multiplexer in pselect6 select poll ppoll; do
+ } > "$TS_OUTPUT" 2>&1
+
+ if read -r -u "${MKFDS[0]}" PID; then
+- if ! cat /proc/"${PID}"/syscall > /dev/null 2>&1; then
++ syscall_line=$(cat /proc/"${PID}"/syscall 2>> "$TS_OUTPUT")
++ syscall_status=$?
++ if [[ "$syscall_status" != 0 ]]; then
+ kill -CONT "${PID}"
+ wait "${MKFDS_PID}"
+ ts_skip_subtest "cannot open /proc/${PID}/syscall"
+ continue
+ fi
++ syscall_n=$(cut -f1 -d' ' <<< "$syscall_line")
++ # We assume the syscall number for the $multiplexer is not zero
++ # on any platforms.
++ if [[ "$syscall_n" == 0 ]]; then
++ kill -CONT "${PID}"
++ wait "${MKFDS_PID}"
++ ts_skip_subtest "incorrect syscall number in /proc/${PID}/syscall"
++ continue
++ fi
++
+ {
+ "${TS_CMD_LSFD}" -n -o ASSOC,XMODE -p "${PID}" -Q '(FD >= 10) && (FD <= 22)'
+ echo "[$multiplexer] ASSOC,XMODE: $?"
diff --git a/debian/rules b/debian/rules
index b917c09..6eb6c6b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -85,14 +85,13 @@ override_dh_auto_install:
#
# Avoid shipping static libraries.
# - libblkid.a is used by e2fsprogs.
- find debian/tmp/usr/lib -name 'lib*.a' \! -name 'libuuid.a' \! -name 'libblkid.a' -delete
+ find debian/tmp/usr/lib -name 'lib*.a' \! -name 'libuuid.a' \! -name 'libblkid.a' -delete -print
#
# Remove programs we do not install
- find debian/tmp/ -name 'addpart*' -delete
- find debian/tmp/ -name 'delpart*' -delete
- find debian/tmp/ -name 'enosys*' -delete
- find debian/tmp/ -name 'irqtop*' -delete
- find debian/tmp/ -name 'setpgid*' -delete
+ find debian/tmp/ -name 'addpart*' -delete -print
+ find debian/tmp/ -name 'delpart*' -delete -print
+ find debian/tmp/ -name 'irqtop*' -delete -print
+ find debian/tmp/ -name 'setpgid*' -delete -print
#
# show installed man pages
find debian/tmp/usr/share/man
diff --git a/debian/util-linux-extra.install b/debian/util-linux-extra.install
index a22f017..114cf23 100755
--- a/debian/util-linux-extra.install
+++ b/debian/util-linux-extra.install
@@ -8,6 +8,7 @@ sbin/hwclock => /usr/sbin/hwclock
sbin/mkfs.bfs usr/sbin/
sbin/mkfs.cramfs usr/sbin/
sbin/mkfs.minix usr/sbin/
+usr/bin/enosys [linux-any]
usr/bin/fadvise [linux-any]
usr/bin/fincore [linux-any]
usr/bin/lsfd [linux-any]
diff --git a/debian/util-linux-extra.manpages b/debian/util-linux-extra.manpages
index c37322d..edc9d1e 100755
--- a/debian/util-linux-extra.manpages
+++ b/debian/util-linux-extra.manpages
@@ -1,4 +1,5 @@
#!/usr/bin/dh-exec
+debian/tmp/usr/share/man/man1/enosys.1 [linux-any]
debian/tmp/usr/share/man/man1/fadvise.1 [linux-any]
debian/tmp/usr/share/man/man1/fincore.1 [linux-any]
debian/tmp/usr/share/man/man1/lsfd.1 [linux-any]
diff --git a/debian/util-linux-locales.install b/debian/util-linux-locales.install
index 46c9a45..251a3b5 100755
--- a/debian/util-linux-locales.install
+++ b/debian/util-linux-locales.install
@@ -121,6 +121,7 @@ debian/tmp/usr/share/man/*/man8/wipefs.8 <!nodoc>
debian/tmp/usr/share/man/*/man8/zramctl.8 <!nodoc> [linux-any]
# util-linux-extra
+debian/tmp/usr/share/man/*/man1/enosys.1 <!nodoc> [linux-any]
debian/tmp/usr/share/man/*/man1/fincore.1 <!nodoc> [linux-any]
debian/tmp/usr/share/man/*/man1/lsirq.1 <!nodoc> [linux-any]
debian/tmp/usr/share/man/*/man1/waitpid.1 <!nodoc> [linux-any]