summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:32:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:32:40 +0000
commitb0d092ba4b4db44701c7c00769a227271b01dc0e (patch)
tree36ca61ed558ec8c3ec6d74afdace85080edb5b88
parentReleasing progress-linux version 2.39.3-10~progress7.99u1. (diff)
downloadutil-linux-b0d092ba4b4db44701c7c00769a227271b01dc0e.tar.xz
util-linux-b0d092ba4b4db44701c7c00769a227271b01dc0e.zip
Merging debian version 2.39.3-11.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/upstream/wall-fix-escape-sequence-Injection-CVE-2024-28085.patch25
-rwxr-xr-xdebian/rules3
4 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2a35dfa..23143fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+util-linux (2.39.3-11) unstable; urgency=medium
+
+ * Apply upstream patch fixing CVE-2024-28085
+ * No longer install wall, write setgid tty
+
+ -- Chris Hofstaedtler <zeha@debian.org> Wed, 27 Mar 2024 16:28:22 +0100
+
util-linux (2.39.3-10~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/series b/debian/patches/series
index 9ddc8d9..c37fe91 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -14,5 +14,6 @@ upstream/cfdisk-fix-menu-behavior-after-writing-changes.patch
upstream/fincore-tests-also-use-nosize-error-file.patch
upstream/build-only-build-test_enosys-if-an-audit-arch-exists.patch
upstream/libuuid-Add-uuid_time64-for-64bit-time_t-on-32bit.patch
+upstream/wall-fix-escape-sequence-Injection-CVE-2024-28085.patch
progress-linux/0001-agetty-prompt.patch
progress-linux/0002-login-prompt.patch
diff --git a/debian/patches/upstream/wall-fix-escape-sequence-Injection-CVE-2024-28085.patch b/debian/patches/upstream/wall-fix-escape-sequence-Injection-CVE-2024-28085.patch
new file mode 100644
index 0000000..1a0acd7
--- /dev/null
+++ b/debian/patches/upstream/wall-fix-escape-sequence-Injection-CVE-2024-28085.patch
@@ -0,0 +1,25 @@
+From: Karel Zak <kzak@redhat.com>
+Date: Thu, 21 Mar 2024 11:16:20 +0100
+Subject: wall: fix escape sequence Injection [CVE-2024-28085]
+
+Let's use for all cases the same output function.
+
+Reported-by: Skyler Ferrante <sjf5462@rit.edu>
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ term-utils/wall.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/term-utils/wall.c b/term-utils/wall.c
+index 377db45..1e7e9ab 100644
+--- a/term-utils/wall.c
++++ b/term-utils/wall.c
+@@ -328,7 +328,7 @@ static char *makemsg(char *fname, char **mvec, int mvecsz,
+ int i;
+
+ for (i = 0; i < mvecsz; i++) {
+- fputs(mvec[i], fs);
++ fputs_careful(mvec[i], fs, '^', true, TERM_WIDTH);
+ if (i < mvecsz - 1)
+ fputc(' ', fs);
+ }
diff --git a/debian/rules b/debian/rules
index 49861f2..6c8db96 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,6 +47,9 @@ CONFOPTS += --disable-cal
# Keep hwclock as GPLv2 (and others)
CONFOPTS += --disable-hwclock-gplv3
+# Reduce setgid programs (cf. CVE-2024-28085)
+CONFOPTS += --disable-use-tty-group
+
# Get the list of binary package, except lib* and *-udeb, from
# debian/control instead of hardcoding the list when installing
# bash-completions below.