summaryrefslogtreecommitdiffstats
path: root/libuuid
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:23:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:23:00 +0000
commit803b3a091c225d48395508a8f9ffa6e08cbddc5b (patch)
treea3168c9e7da8991c423b5978aacf90c3c2b135c1 /libuuid
parentReleasing progress-linux version 2.40-8~progress7.99u1. (diff)
downloadutil-linux-803b3a091c225d48395508a8f9ffa6e08cbddc5b.tar.xz
util-linux-803b3a091c225d48395508a8f9ffa6e08cbddc5b.zip
Merging upstream version 2.40.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libuuid')
-rw-r--r--libuuid/man/uuid.34
-rw-r--r--libuuid/man/uuid_clear.34
-rw-r--r--libuuid/man/uuid_compare.38
-rw-r--r--libuuid/man/uuid_compare.3.adoc2
-rw-r--r--libuuid/man/uuid_copy.38
-rw-r--r--libuuid/man/uuid_copy.3.adoc2
-rw-r--r--libuuid/man/uuid_generate.34
-rw-r--r--libuuid/man/uuid_is_null.38
-rw-r--r--libuuid/man/uuid_is_null.3.adoc2
-rw-r--r--libuuid/man/uuid_parse.310
-rw-r--r--libuuid/man/uuid_parse.3.adoc4
-rw-r--r--libuuid/man/uuid_time.38
-rw-r--r--libuuid/man/uuid_time.3.adoc2
-rw-r--r--libuuid/man/uuid_unparse.312
-rw-r--r--libuuid/man/uuid_unparse.3.adoc6
-rw-r--r--libuuid/meson.build12
16 files changed, 52 insertions, 44 deletions
diff --git a/libuuid/man/uuid.3 b/libuuid/man/uuid.3
index 0b6d8bd..78a33fa 100644
--- a/libuuid/man/uuid.3
+++ b/libuuid/man/uuid.3
@@ -4,10 +4,10 @@
.\" Generator: Asciidoctor 2.0.20
.\" Date: 2024-01-31
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID" "3" "2024-01-31" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
diff --git a/libuuid/man/uuid_clear.3 b/libuuid/man/uuid_clear.3
index 0ba899c..706bb76 100644
--- a/libuuid/man/uuid_clear.3
+++ b/libuuid/man/uuid_clear.3
@@ -4,10 +4,10 @@
.\" Generator: Asciidoctor 2.0.20
.\" Date: 2024-01-31
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_CLEAR" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_CLEAR" "3" "2024-01-31" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
diff --git a/libuuid/man/uuid_compare.3 b/libuuid/man/uuid_compare.3
index 2d37b5e..2359225 100644
--- a/libuuid/man/uuid_compare.3
+++ b/libuuid/man/uuid_compare.3
@@ -2,12 +2,12 @@
.\" Title: uuid_compare
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_COMPARE" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_COMPARE" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,7 +33,7 @@ uuid_compare \- compare whether two UUIDs are the same
.sp
\fB#include <uuid.h>\fP
.sp
-\fBint uuid_compare(uuid_t \fIuu1\fP, uuid_t \fIuu2\fP)\fP
+\fBint uuid_compare(const uuid_t \fIuu1\fP, const uuid_t \fIuu2\fP)\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_compare\fP() function compares the two supplied uuid variables \fIuu1\fP and \fIuu2\fP to each other.
diff --git a/libuuid/man/uuid_compare.3.adoc b/libuuid/man/uuid_compare.3.adoc
index 1d32475..6001167 100644
--- a/libuuid/man/uuid_compare.3.adoc
+++ b/libuuid/man/uuid_compare.3.adoc
@@ -46,7 +46,7 @@ uuid_compare - compare whether two UUIDs are the same
*#include <uuid.h>*
-*int uuid_compare(uuid_t __uu1__, uuid_t __uu2__)*
+*int uuid_compare(const uuid_t __uu1__, const uuid_t __uu2__)*
== DESCRIPTION
diff --git a/libuuid/man/uuid_copy.3 b/libuuid/man/uuid_copy.3
index ce2834f..96d3d2d 100644
--- a/libuuid/man/uuid_copy.3
+++ b/libuuid/man/uuid_copy.3
@@ -2,12 +2,12 @@
.\" Title: uuid_copy
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_COPY" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_COPY" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,7 +33,7 @@ uuid_copy \- copy a UUID value
.sp
\fB#include <uuid.h>\fP
.sp
-\fBvoid uuid_copy(uuid_t \fIdst\fP, uuid_t \fIsrc\fP);\fP
+\fBvoid uuid_copy(uuid_t \fIdst\fP, const uuid_t \fIsrc\fP);\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_copy\fP() function copies the UUID variable \fIsrc\fP to \fIdst\fP.
diff --git a/libuuid/man/uuid_copy.3.adoc b/libuuid/man/uuid_copy.3.adoc
index fee40d6..31c963d 100644
--- a/libuuid/man/uuid_copy.3.adoc
+++ b/libuuid/man/uuid_copy.3.adoc
@@ -46,7 +46,7 @@ uuid_copy - copy a UUID value
*#include <uuid.h>*
-*void uuid_copy(uuid_t __dst__, uuid_t __src__);*
+*void uuid_copy(uuid_t __dst__, const uuid_t __src__);*
== DESCRIPTION
diff --git a/libuuid/man/uuid_generate.3 b/libuuid/man/uuid_generate.3
index cb88247..3f97d30 100644
--- a/libuuid/man/uuid_generate.3
+++ b/libuuid/man/uuid_generate.3
@@ -4,10 +4,10 @@
.\" Generator: Asciidoctor 2.0.20
.\" Date: 2024-01-31
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_GENERATE" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_GENERATE" "3" "2024-01-31" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
diff --git a/libuuid/man/uuid_is_null.3 b/libuuid/man/uuid_is_null.3
index dc61071..00b5473 100644
--- a/libuuid/man/uuid_is_null.3
+++ b/libuuid/man/uuid_is_null.3
@@ -2,12 +2,12 @@
.\" Title: uuid_is_null
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_IS_NULL" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_IS_NULL" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,7 +33,7 @@ uuid_is_null \- compare the value of the UUID to the NULL value
.sp
\fB#include <uuid.h>\fP
.sp
-\fBint uuid_is_null(uuid_t \fIuu\fP);\fP
+\fBint uuid_is_null(const uuid_t \fIuu\fP);\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_is_null\fP() function compares the value of the supplied UUID variable \fIuu\fP to the NULL value. If the value is equal to the NULL UUID, 1 is returned, otherwise 0 is returned.
diff --git a/libuuid/man/uuid_is_null.3.adoc b/libuuid/man/uuid_is_null.3.adoc
index 6fed1d8..23f2bf8 100644
--- a/libuuid/man/uuid_is_null.3.adoc
+++ b/libuuid/man/uuid_is_null.3.adoc
@@ -46,7 +46,7 @@ uuid_is_null - compare the value of the UUID to the NULL value
*#include <uuid.h>*
-*int uuid_is_null(uuid_t __uu__);*
+*int uuid_is_null(const uuid_t __uu__);*
== DESCRIPTION
diff --git a/libuuid/man/uuid_parse.3 b/libuuid/man/uuid_parse.3
index 0a58da9..2e2ae04 100644
--- a/libuuid/man/uuid_parse.3
+++ b/libuuid/man/uuid_parse.3
@@ -2,12 +2,12 @@
.\" Title: uuid_parse
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_PARSE" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_PARSE" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,9 +33,9 @@ uuid_parse \- convert an input UUID string into binary representation
.sp
\fB#include <uuid.h>\fP
.sp
-\fBint uuid_parse(char *\fIin\fP, uuid_t \fIuu\fP);\fP
+\fBint uuid_parse(const char *\fIin\fP, uuid_t \fIuu\fP);\fP
.br
-\fBint uuid_parse_range(char *\fIin_start\fP, char *\fIin_end\fP, uuid_t \fIuu\fP);\fP
+\fBint uuid_parse_range(const char *\fIin_start\fP, const char *\fIin_end\fP, uuid_t \fIuu\fP);\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_parse\fP() function converts the UUID string given by \fIin\fP into the binary representation. The input UUID is a string of the form 1b4e28ba\-2fa1\-11d2\-883f\-b9a761bde3fb (in \fBprintf\fP(3) format "%08x\-%04x\-%04x\-%04x\-%012x", 36 bytes plus the trailing \*(Aq\(rs0\*(Aq).
diff --git a/libuuid/man/uuid_parse.3.adoc b/libuuid/man/uuid_parse.3.adoc
index 8129aae..230023f 100644
--- a/libuuid/man/uuid_parse.3.adoc
+++ b/libuuid/man/uuid_parse.3.adoc
@@ -46,8 +46,8 @@ uuid_parse - convert an input UUID string into binary representation
*#include <uuid.h>*
-*int uuid_parse(char *__in__, uuid_t __uu__);* +
-*int uuid_parse_range(char *__in_start__, char *__in_end__, uuid_t __uu__);*
+*int uuid_parse(const char *__in__, uuid_t __uu__);* +
+*int uuid_parse_range(const char *__in_start__, const char *__in_end__, uuid_t __uu__);*
== DESCRIPTION
diff --git a/libuuid/man/uuid_time.3 b/libuuid/man/uuid_time.3
index 18c9f4f..15f1720 100644
--- a/libuuid/man/uuid_time.3
+++ b/libuuid/man/uuid_time.3
@@ -2,12 +2,12 @@
.\" Title: uuid_time
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_TIME" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_TIME" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,7 +33,7 @@ uuid_time \- extract the time at which the UUID was created
.sp
\fB#include <uuid.h>\fP
.sp
-\fBtime_t uuid_time(uuid_t \fIuu\fP, struct timeval *\fIret_tv\fP)\fP
+\fBtime_t uuid_time(const uuid_t \fIuu\fP, struct timeval *\fIret_tv\fP)\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_time\fP() function extracts the time at which the supplied time\-based UUID \fIuu\fP was created. Note that the UUID creation time is only encoded within certain types of UUIDs. This function can only reasonably expect to extract the creation time for UUIDs created with the \fBuuid_generate_time\fP(3) and \fBuuid_generate_time_safe\fP(3) functions. It may or may not work with UUIDs created by other mechanisms.
diff --git a/libuuid/man/uuid_time.3.adoc b/libuuid/man/uuid_time.3.adoc
index 5497583..5e579e2 100644
--- a/libuuid/man/uuid_time.3.adoc
+++ b/libuuid/man/uuid_time.3.adoc
@@ -46,7 +46,7 @@ uuid_time - extract the time at which the UUID was created
*#include <uuid.h>*
-*time_t uuid_time(uuid_t __uu__, struct timeval *__ret_tv__)*
+*time_t uuid_time(const uuid_t __uu__, struct timeval *__ret_tv__)*
== DESCRIPTION
diff --git a/libuuid/man/uuid_unparse.3 b/libuuid/man/uuid_unparse.3
index 3b86df4..4cf9db6 100644
--- a/libuuid/man/uuid_unparse.3
+++ b/libuuid/man/uuid_unparse.3
@@ -2,12 +2,12 @@
.\" Title: uuid_unparse
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.20
-.\" Date: 2024-01-31
+.\" Date: 2024-05-01
.\" Manual: Programmer's Manual
-.\" Source: util-linux 2.40
+.\" Source: util-linux 2.40.1
.\" Language: English
.\"
-.TH "UUID_UNPARSE" "3" "2024-01-31" "util\-linux 2.40" "Programmer\*(Aqs Manual"
+.TH "UUID_UNPARSE" "3" "2024-05-01" "util\-linux 2.40.1" "Programmer\*(Aqs Manual"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@@ -33,11 +33,11 @@ uuid_unparse \- convert a UUID from binary representation to a string
.sp
\fB#include <uuid.h>\fP
.sp
-\fBvoid uuid_unparse(uuid_t \fIuu\fP, char *\fIout\fP);\fP
+\fBvoid uuid_unparse(const uuid_t \fIuu\fP, char *\fIout\fP);\fP
.br
-\fBvoid uuid_unparse_upper(uuid_t \fIuu\fP, char *\fIout\fP);\fP
+\fBvoid uuid_unparse_upper(const uuid_t \fIuu\fP, char *\fIout\fP);\fP
.br
-\fBvoid uuid_unparse_lower(uuid_t \fIuu\fP, char *\fIout\fP);\fP
+\fBvoid uuid_unparse_lower(const uuid_t \fIuu\fP, char *\fIout\fP);\fP
.SH "DESCRIPTION"
.sp
The \fBuuid_unparse\fP() function converts the supplied UUID \fIuu\fP from the binary representation into a 36\-byte string (plus trailing \*(Aq\(rs0\*(Aq) of the form 1b4e28ba\-2fa1\-11d2\-883f\-0016d3cca427 and stores this value in the character string pointed to by \fIout\fP. The case of the hex digits returned by \fBuuid_unparse\fP() may be upper or lower case, and is dependent on the system\-dependent local default.
diff --git a/libuuid/man/uuid_unparse.3.adoc b/libuuid/man/uuid_unparse.3.adoc
index a14dc8c..20e8cfb 100644
--- a/libuuid/man/uuid_unparse.3.adoc
+++ b/libuuid/man/uuid_unparse.3.adoc
@@ -46,9 +46,9 @@ uuid_unparse - convert a UUID from binary representation to a string
*#include <uuid.h>*
-*void uuid_unparse(uuid_t __uu__, char *__out__);* +
-*void uuid_unparse_upper(uuid_t __uu__, char *__out__);* +
-*void uuid_unparse_lower(uuid_t __uu__, char *__out__);*
+*void uuid_unparse(const uuid_t __uu__, char *__out__);* +
+*void uuid_unparse_upper(const uuid_t __uu__, char *__out__);* +
+*void uuid_unparse_lower(const uuid_t __uu__, char *__out__);*
== DESCRIPTION
diff --git a/libuuid/meson.build b/libuuid/meson.build
index a801b4e..b67b3d5 100644
--- a/libuuid/meson.build
+++ b/libuuid/meson.build
@@ -20,6 +20,14 @@ unparse_c = files('src/unparse.c')
libuuid_sym = 'src/libuuid.sym'
libuuid_sym_path = '@0@/@1@'.format(meson.current_source_dir(), libuuid_sym)
+libuuid_link_depends = []
+libuuid_link_args = []
+
+if cc.has_link_argument('-Wl,--version-script=@0@'.format(libuuid_sym_path))
+ libuuid_link_depends += [libuuid_sym]
+ libuuid_link_args += ['-Wl,--version-script=@0@'.format(libuuid_sym_path)]
+endif
+
lib_uuid = both_libraries(
'uuid',
list_h,
@@ -31,9 +39,9 @@ lib_uuid = both_libraries(
md5_c,
sha1_c,
include_directories : [dir_include, dir_libuuid],
- link_depends : libuuid_sym,
+ link_depends : libuuid_link_depends,
version : libuuid_version,
- link_args : ['-Wl,--version-script=@0@'.format(libuuid_sym_path)],
+ link_args : libuuid_link_args,
dependencies : [socket_libs,
build_libuuid ? [] : disabler()],
install : build_libuuid)