summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a43cd0b..49861f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -85,6 +85,8 @@ override_dh_auto_clean:
# drop arch-overrides, generated in dh_install by dh-exec usage.
rm -f debian/uuid-runtime.install.$(DEB_HOST_ARCH) \
debian/util-linux.install.$(DEB_HOST_ARCH)
+ # remove postinst generated in dh_installdeb
+ rm -f debian/util-linux.postinst
override_dh_install:
ifeq ($(filter stage1,$(DEB_BUILD_PROFILES)),)
@@ -174,3 +176,11 @@ else
@echo "WARNING: non-linux detected, making tests non-fatal."
dh_auto_test --max-parallel=1 || true
endif
+
+execute_before_dh_installdeb:
+ifeq ($(DEB_HOST_ARCH_OS), linux)
+ # due to UL_REQUIRES_LINUX([more]), only set up pager alternative
+ # on linux -- this avoids running uname in the maintainer script
+ # as doing so would be unreliable for chrootless installations
+ cp debian/util-linux.postinst.linux debian/util-linux.postinst
+endif