summaryrefslogtreecommitdiffstats
path: root/Filelist
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 07:39:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 07:40:16 +0000
commit6af24b2457752c0d36aaf9f29f03d39afd09937f (patch)
tree2671b594908d1f971de6b2a2d473f97dfb7291d2 /Filelist
parentReleasing progress-linux version 2:9.1.0016-1~progress7.99u1. (diff)
downloadvim-6af24b2457752c0d36aaf9f29f03d39afd09937f.tar.xz
vim-6af24b2457752c0d36aaf9f29f03d39afd09937f.zip
Merging upstream version 2:9.1.0199.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Filelist')
-rw-r--r--Filelist85
1 files changed, 48 insertions, 37 deletions
diff --git a/Filelist b/Filelist
index d4fbca3..b7b3907 100644
--- a/Filelist
+++ b/Filelist
@@ -1,7 +1,7 @@
# List of distributed Vim files.
# Used by Makefile.
-# source files for all source archives
+# Source files for all source archives.
SRC_ALL = \
.cirrus.yml \
.gitattributes \
@@ -20,6 +20,7 @@ SRC_ALL = \
ci/config.mk*.sed \
ci/if_ver*.vim \
ci/setup-xvfb.sh \
+ ci/remove_snap.sh \
src/Make_all.mak \
src/README.md \
src/alloc.c \
@@ -429,7 +430,7 @@ SRC_ALL = \
src/xdiff/xutils.h \
-# source files for Unix only
+# Source files for Unix-like only.
SRC_UNIX = \
Makefile \
Filelist \
@@ -495,7 +496,7 @@ SRC_UNIX = \
src/which.sh \
src/xxd/Makefile \
-# source files for both DOS and Unix
+# Source files for both MS Windows and Unix-like.
SRC_DOS_UNIX = \
src/gui_xim.c \
src/if_cscope.c \
@@ -521,7 +522,7 @@ SRC_DOS_UNIX = \
src/proto/if_tcl.pro \
src/typemap \
-# source files for MS-Windows (also in the extra archive)
+# Source files for MS Windows (also in the extra archive).
SRC_DOS = \
src/GvimExt/*.mak \
src/GvimExt/GvimExt.reg \
@@ -597,7 +598,7 @@ SRC_DOS = \
nsis/lang/*.nsi \
uninstall.txt \
-# source files for DOS without CR/LF translation (also in the extra archive)
+# Source files for MS Windows without CR/LF translation (also in the extra archive).
SRC_DOS_BIN = \
src/tearoff.bmp \
src/tools.bmp \
@@ -614,10 +615,10 @@ SRC_DOS_BIN = \
runtime/bitmaps/vim.ico \
nsis/icons.zip \
-# source files for Amiga, DOS, etc. (also in the extra archive)
+# Source files for Amiga, DOS, etc. (also in the extra archive).
SRC_AMI_DOS = \
-# source files for Amiga (also in the extra archive)
+# Source files for Amiga (also in the extra archive).
SRC_AMI = \
README_amisrc.txt \
README_amisrc.txt.info \
@@ -631,7 +632,7 @@ SRC_AMI = \
src/testdir/amiga.vim \
src/xxd/Make_amiga.mak \
-# source files for Haiku (also in the extra archive)
+# Source files for Haiku (also in the extra archive).
SRC_HAIKU = \
README_haiku.txt \
src/os_haiku.h \
@@ -640,7 +641,7 @@ SRC_HAIKU = \
src/gui_haiku.h \
src/proto/gui_haiku.pro \
-# source files for the Mac (also in the extra archive)
+# Source files for the Mac (also in the extra archive).
SRC_MAC = \
src/INSTALLmac.txt \
src/os_mac.h \
@@ -649,7 +650,7 @@ SRC_MAC = \
src/proto/os_mac_conv.pro \
src/proto/os_macosx.pro \
-# source files for VMS (in the extra archive)
+# Source files for VMS (in the extra archive).
SRC_VMS = \
src/INSTALLvms.txt \
src/Make_vms.mms \
@@ -663,7 +664,7 @@ SRC_VMS = \
src/xxd/Make_vms.mms \
vimtutor.com \
-# source files for QNX (in the extra archive)
+# Source files for QNX (in the extra archive).
SRC_QNX = \
src/os_qnx.c \
src/os_qnx.h \
@@ -671,7 +672,7 @@ SRC_QNX = \
src/proto/gui_photon.pro \
src/proto/os_qnx.pro \
-# source files for the extra archive (all sources that are not for Unix)
+# Source files for the extra archive (all sources that are not for Unix).
SRC_EXTRA = \
$(SRC_AMI) \
$(SRC_AMI_DOS) \
@@ -686,7 +687,7 @@ SRC_EXTRA = \
src/os_vms_fix.com \
src/toolbar.phi \
-# runtime files for all distributions
+# Runtime files for all distributions.
RT_ALL = \
README.txt \
README.md \
@@ -777,12 +778,12 @@ RT_ALL = \
runtime/pack/dist/opt/swapmouse/plugin/swapmouse.vim \
runtime/pack/dist/opt/termdebug/plugin/termdebug.vim \
-# runtime files for all distributions without CR-NL translation
+# Runtime files for all distributions without CR/LF translation.
RT_ALL_BIN = \
runtime/doc/tags \
runtime/print/*.ps \
-# runtime script files
+# Runtime script files.
RT_SCRIPTS = \
runtime/filetype.vim \
runtime/scripts.vim \
@@ -824,10 +825,17 @@ RT_SCRIPTS = \
runtime/syntax/Makefile \
runtime/syntax/testdir/README.txt \
runtime/syntax/testdir/runtest.vim \
+ runtime/syntax/testdir/ftplugin/*.* \
runtime/syntax/testdir/input/*.* \
+ runtime/syntax/testdir/input/setup/*.* \
runtime/syntax/testdir/dumps/*.dump \
+ runtime/syntax/generator/Makefile \
+ runtime/syntax/generator/README.md \
+ runtime/syntax/generator/gen_syntax_vim.vim \
+ runtime/syntax/generator/update_date.vim \
+ runtime/syntax/generator/vim.vim.base \
-# Unix runtime
+# Unix-like runtime.
RT_UNIX = \
README_unix.txt \
runtime/hi16-action-make.png \
@@ -835,7 +843,7 @@ RT_UNIX = \
runtime/gvim.desktop \
runtime/vim.desktop \
-# Unix and DOS runtime without CR-LF translation
+# Unix-like and MS Windows runtime without CR/LF translation.
RT_UNIX_DOS_BIN = \
runtime/vim16x16.gif \
runtime/vim16x16.png \
@@ -847,10 +855,10 @@ RT_UNIX_DOS_BIN = \
runtime/vim48x48.png \
runtime/vim48x48.xpm \
-# runtime not for unix or extra
+# Runtime not for Unix-like or extra.
RT_NO_UNIX = \
-# runtime for Amiga (also in the extra archive)
+# Runtime for Amiga (also in the extra archive).
RT_AMI_DOS = \
runtime/doc/evim.man \
runtime/doc/vim.man \
@@ -858,20 +866,22 @@ RT_AMI_DOS = \
runtime/doc/vimtutor.man \
runtime/doc/xxd.man \
-# DOS runtime (also in the extra archive)
+# MS Windows runtime (also in the extra archive).
RT_DOS = \
README_dos.txt \
runtime/doc/Make_mvc.mak \
+ runtime/indent/Make_mvc.mak \
runtime/tutor/Make_mvc.mak \
runtime/lang/Make_mvc.mak \
vimtutor.bat \
-# DOS runtime without CR-LF translation (also in the extra archive)
+# MS Windows runtime without CR/LF translation (also in the extra archive).
RT_DOS_BIN = \
runtime/vimlogo.cdr \
runtime/vimlogo.eps \
runtime/vimlogo.gif \
runtime/vimlogo.pdf \
+ runtime/vimlogo.svg \
# Amiga runtime (also in the extra archive)
RT_AMI = \
@@ -893,7 +903,7 @@ RT_AMI = \
runtime/tutor.info \
runtime/tutor/*.info \
-# runtime files in extra archive
+# Runtime files in extra archive.
RT_EXTRA = \
$(RT_AMI) \
$(RT_AMI_DOS) \
@@ -901,46 +911,46 @@ RT_EXTRA = \
$(RT_DOS_BIN) \
README_mac.txt \
-# included in all Amiga archives
+# Included in all Amiga archives.
ROOT_AMI = \
Contents \
Contents.info \
runtime.info \
vimdir.info \
-# root files for the extra archive
+# Root files for the extra archive.
ROOT_EXTRA = \
$(ROOT_AMI) \
-# files for Amiga small binary (also in extra archive)
+# Files for Amiga small binary (also in extra archive).
BIN_AMI = \
README_amibin.txt \
README_amibin.txt.info \
Vim.info \
Xxd.info \
-# files for DOS binary (also in extra archive)
+# Files for MS Windows binary (also in extra archive).
BIN_DOS = \
README_bindos.txt \
uninstall.txt \
-# files for Win32 OLE binary (also in extra archive)
+# Files for Win32 OLE binary (also in extra archive).
BIN_OLE = \
README_ole.txt \
-# files for Win32s binary (also in extra archive)
+# Files for Win32s binary (also in extra archive).
BIN_W32S = \
README_w32s.txt \
-# files for VMS binary (also in extra archive)
+# Files for VMS binary (also in extra archive).
BIN_VMS = \
README_vms.txt \
-# files for OS/2 binary (also in extra archive)
+# Files for OS/2 binary (also in extra archive).
BIN_OS2 = \
README_os2.txt \
-# binary files for extra archive
+# Binary files for extra archive.
BIN_EXTRA = \
$(BIN_AMI) \
$(BIN_DOS) \
@@ -949,7 +959,7 @@ BIN_EXTRA = \
$(BIN_VMS) \
$(BIN_OS2) \
-# all files for extra archive
+# All files for extra archive.
EXTRA = \
$(BIN_EXTRA) \
$(ROOT_EXTRA) \
@@ -958,7 +968,7 @@ EXTRA = \
README_extra.txt \
runtime/vimlogo.xpm \
-# files in READMEdir that are included from the top dir
+# Files in READMEdir that are included from the top dir.
IN_README_DIR = \
README.txt.info \
README_ami.txt \
@@ -978,6 +988,7 @@ IN_README_DIR = \
README_src.txt \
README_srcdos.txt \
README_unix.txt \
+ README_vimlogo.txt \
README_vms.txt \
README_w32s.txt \
Contents \
@@ -988,7 +999,7 @@ IN_README_DIR = \
src.info \
vimdir.info \
-# generic language files
+# Generic language files.
LANG_GEN = \
runtime/doc/*-da.1 \
runtime/doc/*-da.UTF-8.1 \
@@ -1041,7 +1052,7 @@ LANG_GEN = \
runtime/spell/main.aap \
runtime/spell/*.vim \
-# generic language files, binary
+# Generic language files, binary.
LANG_GEN_BIN = \
runtime/spell/README_en.txt \
runtime/spell/en.ascii.spl \
@@ -1051,7 +1062,7 @@ LANG_GEN_BIN = \
runtime/spell/en.latin1.sug \
runtime/spell/en.utf-8.sug \
-# all files for lang archive
+# All files for lang archive.
LANG_SRC = \
src/po/README.txt \
src/po/README_mingw.txt \
@@ -1071,7 +1082,7 @@ LANG_SRC = \
src/po/big5corr.c \
src/po/*.po \
-# the language files for the Win32 lang archive
+# The language files for the Win32 lang archive.
LANG_DOS = \
src/po/*.mo \