summaryrefslogtreecommitdiffstats
path: root/runtime/syntax/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:09:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:09:20 +0000
commit029f72b1a93430b24b88eb3a72c6114d9f149737 (patch)
tree765d5c2041967f9c6fef195fe343d9234a030e90 /runtime/syntax/Makefile
parentInitial commit. (diff)
downloadvim-029f72b1a93430b24b88eb3a72c6114d9f149737.tar.xz
vim-029f72b1a93430b24b88eb3a72c6114d9f149737.zip
Adding upstream version 2:9.1.0016.upstream/2%9.1.0016
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'runtime/syntax/Makefile')
-rw-r--r--runtime/syntax/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/runtime/syntax/Makefile b/runtime/syntax/Makefile
new file mode 100644
index 0000000..f3b578c
--- /dev/null
+++ b/runtime/syntax/Makefile
@@ -0,0 +1,35 @@
+# Portable Makefile for running syntax tests.
+
+# Override this if needed, the default assumes Vim was build in the src dir.
+#VIMPROG = vim
+VIMPROG = ../../src/vim
+
+# "runtime" relative to "runtime/syntax/testdir"
+VIMRUNTIME = ../..
+
+# Uncomment this line to use valgrind for memory leaks and extra warnings.
+# VALGRIND = valgrind --tool=memcheck --leak-check=yes --num-callers=45 --log-file=valgrind.$*
+
+# ENVVARS = LC_ALL=C LANG=C LANGUAGE=C
+
+RUN_VIMTEST = VIMRUNTIME=$(VIMRUNTIME) $(VALGRIND) $(ENVVARS) ../$(VIMPROG) -f $(GUI_FLAG)
+
+# Uncomment this line for debugging
+# DEBUGLOG = --log testlog
+
+# Run the tests that didn't run yet or failed previously.
+# If a test succeeds a testdir/done/{name} file will be written.
+# If a test fails a testdir/failed/{name}.dump file will be written.
+# Progress and error messages can be found in "testdir/messages".
+test:
+ @# the "vimcmd" file is used by the screendump utils
+ @echo "../$(VIMPROG)" > testdir/vimcmd
+ @echo "$(RUN_VIMTEST)" >> testdir/vimcmd
+ VIMRUNTIME=$(VIMRUNTIME) $(VIMPROG) --clean --not-a-term $(DEBUGLOG) -u testdir/runtest.vim
+ @# FIXME: Temporarily show the whole file to find out what goes wrong
+ @#if [ -f testdir/messages ]; then tail -n 6 testdir/messages; fi
+ @if [ -f testdir/messages ]; then cat testdir/messages; fi
+
+
+clean testclean:
+ rm -f testdir/failed/* testdir/done/* testdir/vimcmd testdir/messages