summaryrefslogtreecommitdiffstats
path: root/runtime/syntax/generator/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:05:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:05:19 +0000
commita4e9136f68a40b1cb0eb6df5a5f06603224a87f4 (patch)
treeba32e0d0069ad6adfd6b32d05161a03eea5e4c7c /runtime/syntax/generator/Makefile
parentReleasing progress-linux version 2:9.1.0496-1~progress7.99u1. (diff)
downloadvim-a4e9136f68a40b1cb0eb6df5a5f06603224a87f4.tar.xz
vim-a4e9136f68a40b1cb0eb6df5a5f06603224a87f4.zip
Merging upstream version 2:9.1.0698.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'runtime/syntax/generator/Makefile')
-rw-r--r--runtime/syntax/generator/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/runtime/syntax/generator/Makefile b/runtime/syntax/generator/Makefile
index 3cf4b95..a7ccba3 100644
--- a/runtime/syntax/generator/Makefile
+++ b/runtime/syntax/generator/Makefile
@@ -1,5 +1,5 @@
VIM_SRCDIR = ../../../src
-RUN_VIM = $(VIM_SRCDIR)/vim -N -u NONE -i NONE -n
+RUN_VIMPROG = $(VIM_SRCDIR)/vim -N -u NONE -i NONE -n
REVISION ?= $(shell date +%Y-%m-%dT%H:%M:%S%:z)
SRC = $(VIM_SRCDIR)/eval.c $(VIM_SRCDIR)/ex_cmds.h $(VIM_SRCDIR)/ex_docmd.c \
@@ -15,13 +15,13 @@ generate: vim.vim
vim.vim: vim.vim.rc update_date.vim
@echo "Generating vim.vim ..."
@cp -f vim.vim.rc ../vim.vim
- @$(RUN_VIM) -S update_date.vim
+ @$(RUN_VIMPROG) -S update_date.vim
@echo "done."
vim.vim.rc: gen_syntax_vim.vim vim.vim.base $(SRC)
@echo "Generating vim.vim.rc ..."
@rm -f sanity_check.err generator.err
- @$(RUN_VIM) -S gen_syntax_vim.vim
+ @$(RUN_VIMPROG) -S gen_syntax_vim.vim
@if test -f sanity_check.err ; then \
echo ; \
echo "Sanity errors:" ; \