summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:17:27 +0000
commitf215e02bf85f68d3a6106c2a1f4f7f063f819064 (patch)
tree6bb5b92c046312c4e95ac2620b10ddf482d3fa8b /src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py
parentInitial commit. (diff)
downloadvirtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.tar.xz
virtualbox-f215e02bf85f68d3a6106c2a1f4f7f063f819064.zip
Adding upstream version 7.0.14-dfsg.upstream/7.0.14-dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py')
-rwxr-xr-xsrc/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py
new file mode 100755
index 00000000..7ccc6d8c
--- /dev/null
+++ b/src/VBox/Devices/EFI/Firmware/BaseTools/Source/C/PyEfiCompressor/setup.py
@@ -0,0 +1,37 @@
+## @file
+# package and install PyEfiCompressor extension
+#
+# Copyright (c) 2008, Intel Corporation. All rights reserved.<BR>
+#
+# SPDX-License-Identifier: BSD-2-Clause-Patent
+#
+
+##
+# Import Modules
+#
+from distutils.core import setup, Extension
+import os
+
+if 'BASE_TOOLS_PATH' not in os.environ:
+ raise "Please define BASE_TOOLS_PATH to the root of base tools tree"
+
+BaseToolsDir = os.environ['BASE_TOOLS_PATH']
+setup(
+ name="EfiCompressor",
+ version="0.01",
+ ext_modules=[
+ Extension(
+ 'EfiCompressor',
+ sources=[
+ os.path.join(BaseToolsDir, 'Source', 'C', 'Common', 'Decompress.c'),
+ 'EfiCompressor.c'
+ ],
+ include_dirs=[
+ os.path.join(BaseToolsDir, 'Source', 'C', 'Include'),
+ os.path.join(BaseToolsDir, 'Source', 'C', 'Include', 'Ia32'),
+ os.path.join(BaseToolsDir, 'Source', 'C', 'Common')
+ ],
+ )
+ ],
+ )
+