summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/darwin/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 22:55:52 +0000
commitcd47c2446f1a9dee96610f298989848f8986a8be (patch)
tree02c30d62a9164987d0aaba2f72c58a50053205d6 /src/VBox/Installer/darwin/Makefile.kmk
parentReleasing progress-linux version 7.0.14-dfsg-4~progress7.99u1. (diff)
downloadvirtualbox-cd47c2446f1a9dee96610f298989848f8986a8be.tar.xz
virtualbox-cd47c2446f1a9dee96610f298989848f8986a8be.zip
Merging upstream version 7.0.16-dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Installer/darwin/Makefile.kmk')
-rw-r--r--src/VBox/Installer/darwin/Makefile.kmk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/VBox/Installer/darwin/Makefile.kmk b/src/VBox/Installer/darwin/Makefile.kmk
index 494fd990..1b7a16f8 100644
--- a/src/VBox/Installer/darwin/Makefile.kmk
+++ b/src/VBox/Installer/darwin/Makefile.kmk
@@ -483,6 +483,12 @@ if defined(VBOX_WITH_PYTHON) && !defined(VBOX_WITHOUT_VBOXPYTHON_FOR_OSX_10_7)
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxPython2_7.so
endif
+if defined(VBOX_WITH_PYTHON) \
+ && !defined(VBOX_WITHOUT_PYTHON_LIMITED_API) \
+ && exists "$(VBOX_PATH_DIST)/VirtualBox.app/Contents/MacOS/VBoxPython3.so"
+ VBOX_DI_VBAPP_DYLIBS += \
+ MacOS/VBoxPython3.so
+endif
ifdef VBOX_WITH_VMSVGA3D
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxSVGA3D.dylib \