summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/darwin/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Installer/darwin/Makefile.kmk')
-rw-r--r--src/VBox/Installer/darwin/Makefile.kmk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/VBox/Installer/darwin/Makefile.kmk b/src/VBox/Installer/darwin/Makefile.kmk
index 494fd990..1b7a16f8 100644
--- a/src/VBox/Installer/darwin/Makefile.kmk
+++ b/src/VBox/Installer/darwin/Makefile.kmk
@@ -483,6 +483,12 @@ if defined(VBOX_WITH_PYTHON) && !defined(VBOX_WITHOUT_VBOXPYTHON_FOR_OSX_10_7)
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxPython2_7.so
endif
+if defined(VBOX_WITH_PYTHON) \
+ && !defined(VBOX_WITHOUT_PYTHON_LIMITED_API) \
+ && exists "$(VBOX_PATH_DIST)/VirtualBox.app/Contents/MacOS/VBoxPython3.so"
+ VBOX_DI_VBAPP_DYLIBS += \
+ MacOS/VBoxPython3.so
+endif
ifdef VBOX_WITH_VMSVGA3D
VBOX_DI_VBAPP_DYLIBS += \
MacOS/VBoxSVGA3D.dylib \