summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Installer')
-rw-r--r--src/VBox/Installer/darwin/Makefile.kmk4
-rw-r--r--src/VBox/Installer/linux/distributions_deb1
-rw-r--r--src/VBox/Installer/win/UserInterface.wxi7
3 files changed, 7 insertions, 5 deletions
diff --git a/src/VBox/Installer/darwin/Makefile.kmk b/src/VBox/Installer/darwin/Makefile.kmk
index 1b7a16f8..beffa086 100644
--- a/src/VBox/Installer/darwin/Makefile.kmk
+++ b/src/VBox/Installer/darwin/Makefile.kmk
@@ -189,7 +189,9 @@ ifdef VBOX_SIGNING_MODE
$(call VBOX_SIGN_DMG_FN,$@,org.virtualbox.dmg)
if $(intersects darwin darwin_notarize all 1,$(VBOX_WITH_CORP_CODE_SIGNING))
@# Notarize the signed dmg (includes stapling).
- $(call VBOX_NOTARIZE_FILE_FN,$@,org.virtualbox.VirtualBox.$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD).$(VBOX_SVN_REV))
+ $(call VBOX_NOTARIZE_FILE_FN,$@,org.virtualbox.VirtualBox.$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD).$(VBOX_SVN_REV),$(call VBOX_DIRX,$@).tmp)
+ $(MV) -f $(call VBOX_DIRX,$@).tmp/$(call VBOX_NOTDIRX,$@) $@
+ $(RMDIR) $(call VBOX_DIRX,$@).tmp
endif
endif
endif
diff --git a/src/VBox/Installer/linux/distributions_deb b/src/VBox/Installer/linux/distributions_deb
index 072f3323..3ece6095 100644
--- a/src/VBox/Installer/linux/distributions_deb
+++ b/src/VBox/Installer/linux/distributions_deb
@@ -2,6 +2,7 @@ _Debian_sid = DEBIAN_12_0
_Debian_bookworm = DEBIAN_12_0
_Debian_bullseye = DEBIAN_11_0
_Debian_buster = DEBIAN_10_0
+_Ubuntu_noble = UBUNTU_24_04
_Ubuntu_jammy = UBUNTU_22_04
_Ubuntu_focal = UBUNTU_20_04
_Ubuntu_eoan = UBUNTU_19_10
diff --git a/src/VBox/Installer/win/UserInterface.wxi b/src/VBox/Installer/win/UserInterface.wxi
index cd4c2660..b8fff529 100644
--- a/src/VBox/Installer/win/UserInterface.wxi
+++ b/src/VBox/Installer/win/UserInterface.wxi
@@ -364,7 +364,6 @@
<Control Id="Text" Type="Text" X="25" Y="70" Width="320" Height="20">
<Text>!(loc.Customize2Dlg_Desc)</Text>
</Control>
-<?if $(env.VBOX_WITH_QTGUI) = "yes" ?>
<!-- Note the gray background behind the checkboxes. Unfortunately there's no easy way to
fix this, without fixing it in the WiX source code. Because the control's background
uses the default dialog background color, changing the background image for the dialog to
@@ -388,7 +387,7 @@
Property="VBOX_REGISTERFILEEXTENSIONS" CheckBoxValue="1" Default="no">
<Text>!(loc.Customize2Dlg_RegisterFileExtensions)</Text>
</Control>
-<?endif?> <!-- VBOX_WITH_QTGUI -->
+
<Control Id="Next" Type="PushButton" X="236" Y="243" Width="56" Height="17" Default="yes" Text="!(loc.ButtonText_Next)" />
<Control Id="Back" Type="PushButton" X="180" Y="243" Width="56" Height="17" Text="!(loc.ButtonText_Back)" />
@@ -1169,11 +1168,11 @@
<!-- Property which defines whether the installer checks the serial number or not. -->
<Property Id="VBOX_SHOW_SERIAL_CHECK_DLG">1</Property>
<?endif?>
-<?if $(env.VBOX_WITH_QTGUI) = "no" ?>
+<?if $(env.VBOX_WITH_QTGUI) = "yes" ?>
<!-- Property which defines whether to show the second customization dialog. This second customization
dialog only is needed for GUI-based options, so skip if we either don't ship FE/Qt or don't show
the (first) customization dialog. -->
- <Property Id="VBOX_SHOW_CUSTOMIZE2_DLG"><![CDATA[VBOX_SHOW_CUSTOMIZE_DLG]]></Property>
+ <Property Id="VBOX_SHOW_CUSTOMIZE2_DLG">1</Property>
<?endif?>