summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:11:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:11:57 +0000
commit1c4389784f63b1e30e0bbc25fd5c19ddb04fb569 (patch)
treed136acd78002cfb22e5ebce689f948c5d1580412
parentMerging upstream version 0.0~git20230621.7018e24. (diff)
downloadwasi-libc-1c4389784f63b1e30e0bbc25fd5c19ddb04fb569.tar.xz
wasi-libc-1c4389784f63b1e30e0bbc25fd5c19ddb04fb569.zip
Merging debian version 0.0~git20230621.7018e24-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/debian-flags.patch47
-rw-r--r--debian/patches/disable-warning.patch2
-rw-r--r--debian/patches/dont-rebuild-install.patch16
-rw-r--r--debian/patches/series1
5 files changed, 15 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b56559..fdf06fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+wasi-libc (0.0~git20230621.7018e24-1) experimental; urgency=medium
+
+ * new upstream version needed for rustc 1.72.1+
+
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Fri, 24 May 2024 10:30:30 +0200
+
wasi-libc (0.0~git20230113.4362b18-3~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/debian-flags.patch b/debian/patches/debian-flags.patch
deleted file mode 100644
index b173f84..0000000
--- a/debian/patches/debian-flags.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Author: Ximin Luo <infinity0@debian.org>
-Description: patch aligning expected definitions to Debian
-peculiarities/toolchain versions.
-Forwarded: not-needed
-
-Index: wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
-===================================================================
---- wasi-libc.orig/expected/wasm32-wasi-threads/predefined-macros.txt
-+++ wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
-@@ -1119,7 +1119,6 @@
- #define NAN (0.0f/0.0f)
- #define NBBY 8
- #define NCARGS 131072
--#define NDEBUG 1
- #define ND_NA_FLAG_OVERRIDE 0x00000020
- #define ND_NA_FLAG_ROUTER 0x00000080
- #define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3112,7 +3111,7 @@
- #define and_eq &=
- #define asin(x) __tg_real_complex(asin, (x))
- #define asinh(x) __tg_real_complex(asinh, (x))
--#define assert(x) (void)0
-+#define assert(x) ((void)((x) || (__assert_fail(#x, __FILE__, __LINE__, __func__),0)))
- #define atan(x) __tg_real_complex(atan, (x))
- #define atan2(x,y) __tg_real_2(atan2, (x), (y))
- #define atanh(x) __tg_real_complex(atanh, (x))
-Index: wasi-libc/expected/wasm32-wasi/predefined-macros.txt
-===================================================================
---- wasi-libc.orig/expected/wasm32-wasi/predefined-macros.txt
-+++ wasi-libc/expected/wasm32-wasi/predefined-macros.txt
-@@ -1119,7 +1119,6 @@
- #define NAN (0.0f/0.0f)
- #define NBBY 8
- #define NCARGS 131072
--#define NDEBUG 1
- #define ND_NA_FLAG_OVERRIDE 0x00000020
- #define ND_NA_FLAG_ROUTER 0x00000080
- #define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3073,7 +3072,7 @@
- #define and_eq &=
- #define asin(x) __tg_real_complex(asin, (x))
- #define asinh(x) __tg_real_complex(asinh, (x))
--#define assert(x) (void)0
-+#define assert(x) ((void)((x) || (__assert_fail(#x, __FILE__, __LINE__, __func__),0)))
- #define atan(x) __tg_real_complex(atan, (x))
- #define atan2(x,y) __tg_real_2(atan2, (x), (y))
- #define atanh(x) __tg_real_complex(atanh, (x))
diff --git a/debian/patches/disable-warning.patch b/debian/patches/disable-warning.patch
index c6256b5..f38b07d 100644
--- a/debian/patches/disable-warning.patch
+++ b/debian/patches/disable-warning.patch
@@ -6,7 +6,7 @@ Index: wasi-libc/Makefile
===================================================================
--- wasi-libc.orig/Makefile
+++ wasi-libc/Makefile
-@@ -310,6 +310,7 @@ CFLAGS += -Wall -Wextra -Werror \
+@@ -315,6 +315,7 @@ CFLAGS += -Wall -Wextra -Werror \
-Wno-missing-braces \
-Wno-ignored-pragmas \
-Wno-unused-but-set-variable \
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index a9cf7f7..d69946d 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -6,25 +6,25 @@ Index: wasi-libc/Makefile
===================================================================
--- wasi-libc.orig/Makefile
+++ wasi-libc/Makefile
-@@ -577,6 +577,8 @@ include_dirs:
+@@ -584,6 +584,8 @@ include_dirs:
# Remove selected header files.
$(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
+ touch $@
+
- startup_files: include_dirs
+ startup_files: include_dirs $(LIBC_BOTTOM_HALF_CRT_OBJS)
#
- # Build the startup files.
-@@ -587,6 +589,8 @@ startup_files: include_dirs
+ # Install the startup files (crt1.o etc).
+@@ -591,6 +593,8 @@ startup_files: include_dirs $(LIBC_BOTTO
mkdir -p "$(SYSROOT_LIB)" && \
- mv *.o "$(SYSROOT_LIB)"
+ cp $(LIBC_BOTTOM_HALF_CRT_OBJS) "$(SYSROOT_LIB)"
+ touch $@
+
libc: include_dirs \
$(SYSROOT_LIB)/libc.a \
$(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -596,6 +600,8 @@ libc: include_dirs \
+@@ -600,6 +604,8 @@ libc: include_dirs \
$(SYSROOT_LIB)/libwasi-emulated-getpid.a \
$(SYSROOT_LIB)/libwasi-emulated-signal.a
@@ -33,7 +33,7 @@ Index: wasi-libc/Makefile
finish: startup_files libc
#
# Create empty placeholder libraries.
-@@ -607,6 +613,7 @@ finish: startup_files libc
+@@ -611,6 +617,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -41,7 +41,7 @@ Index: wasi-libc/Makefile
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -712,5 +719,6 @@ install: finish
+@@ -722,5 +729,6 @@ install: finish
clean:
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"
diff --git a/debian/patches/series b/debian/patches/series
index cf9c25b..bedf490 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,2 @@
dont-rebuild-install.patch
-debian-flags.patch
disable-warning.patch